1

On upgrading to 16.04 from 15.10, my font size was tiny. Somewhere I found the suggestion to go to:

System Settings > Display and Monitor > Display Configuration > Scale Display

And change the scale setting. I did this (changed it to 3), it change the size of the GUI but not the font, and I eventually fixed the font size by setting the DPI in the xorg.conf generated by nvidia-settings. I would now like to undo the scale display setting. But I can't because now the GUI is so large that that part of the Display and Monitor window is off the screen. (In fact, I can only get to Display and Monitor by changing System Settings to the tree view, otherwise it's off the screen as well.) There is a scroll bar, but it won't scroll far enough.

I though I had found the file where this is stored in, ~/.config/startupconfig, which has the line:

kdeglobals_kscreen_scalefactor=3

However, when I change the 3 to a 1, it turns back to a 3 next time I restart KDE and the problem persists.

I tried running systemsettings5 using ssh to display it on another computer, but it crashes as soon as I go into the Display and Monitor part.

Any idea of where this is stored or how I could reset it without losing all my other KDE settings?

2

In case anyone else runs into this, this is what I did (though I imagine there must be a better way): I got a spare monitor and connected it to the computer (after turning it off), along with the original monitor. (Fortunately my video card had multiple plugs.) On rebooting, I used nvidia-settings to move the new monitor's position to below the other one. That gave enough room for all (or at least enough) of the System Settings window to be visible, so I could get to the Scale Display bit and reset it back to 1. Then I shutdown the computer and removed the extra monitor. On restart, the GUI was back to normal size and I could see all of the System Settings window.

0

To reset scaling settings in KDE5 I did the following:

  1. Removed [KScreen] section (it contained two options - ScaleFactor and ScreenScaleFactors) from ~/.config/kdeglobals.
  2. Commented kdeglobals_kscreen_screenscalefactors= in ~/.config/startupconfig.

This worked.

0

This worked for me: Start a terminal window CTRL ALT T In the terminal, type dconf reset -f / Then type exit to close the terminal window. That will get you back to your tiny fonts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.