13

After I resume from suspend, or disabling WiFi & re-enable or disable networking and re-enable or connecting via ethernet and then unplugging cable, I pickup and connect via wifi internet connection.

But this is displayed in Ubuntu networking as an ethernet connection, and critically for me does not show Wireless Networks that are indeed available.

This is pain as need to connect/view multiple multiple Wireless Networks.

Machine runs Ubuntu MATE 16.04, x220 Thinkpad, updated to latest BIOS. Wireless card is Intel Centrino advanced-n 6205. Using Intel iwlwifi driver.

I have disabled Wireless N - via modifying /etc/modprobe.d/iwlwifi.conf file, added

options iwlwifi 11n_disable=1

EDIT: as per David's request here are the Network diagnostics Pre Resume (ie. Laptop wireless network list showing all available networks for connections)

Working_ wireless_networking_list

and post Suspend, then Resume [lid closed; then opened], where the list of available Wi-Fi networks has disappeared, but Laptop has connected to the last connected network before suspend [ie. was not moved to a new location]

post suspend then resume

Thanks.

  • 1
    i am facing the same issue – shiv garg Apr 28 '16 at 3:57
  • This fixed things for me! askubuntu.com/questions/761180/…. Thanks for posting JK – sprocketoctopus Apr 28 '16 at 6:06
  • Please note this fix NO LONGER works for me - from yesterday - after a month or so or working absolutely perfectly fine. (X220 Lenevo Laptop, 16.04 MATE edition.) ie. back to the same problem of NOT indicating Networks available on Resume, and connecting to Wireless showing connected to an unknown network via ethernet connected symbol. I suspect it broke yesterday after a rather larger system update that was pushed out yesterday. Could others please check if the same happens to their system? – sprocketoctopus May 25 '16 at 0:18
  • same for me (both Unity and Xfce) after installing 16.04 - wifi works but nothing shows up in nm applet – jena Jun 15 '16 at 15:41
  • 1
    Could you please run the network diagnostics once with a working wireless network and once after it ceased to work and edit your question to include a link to the result? – David Foerster Jul 12 '16 at 20:42
3

Have you tried to disable power management on your wireless card?? I have different wireless card, but I was having a similar issue with my rtle8723be card and forcing the power management feature to be disabled worked. power management on some WiFi cards are an experimental option.

For your WiFi kernel module I found this:

sudo nano -w /etc/modprobe.d/iwlwifi.conf 

and adding this line to the bottom:

options iwlwifi power_save=0 

to exit nano and save:

ctrl-x, Y, then press enter

to unload module:

sudo modprobe -r iwlwifi

now to reload the module:

sudo modprobe iwlwifi 

if that doesn't you work you can try changing that line to:

options iwlwifi power_save=0 d0i3_disable=1 uapsd_disable=1

exit nano, save file.

then unload module:

sudo modprobe -r iwlwifi

reload the module:

sudo modprobe iwlwifi 
|improve this answer|||||
  • I have checked my wireless network card setup and I think I do not have power saving enabled. From the Network Diagnostics mentioned above: [iwlwifi] parm: power_save:enable WiFi power management (default: disable) (bool) – sprocketoctopus Jul 14 '16 at 3:46
  • 1
    It was worth a shot.. If it worked fine on an older kernel, is it possible to load the module for the older kernel on the 16.04 kernel (4.4). – Ellie187 Jul 14 '16 at 21:57
  • 1
    I tried to edit the previous comment to also suggest upgrading to the latest stable kernel (4.6.3), as it mentions "has multiple network improvements" I followed these instructions for upgrading to the latest stable kernel on Ubuntu (and derivatives): ubuntumaniac.com/2016/06/… – Ellie187 Jul 14 '16 at 22:06
  • Thanks Ellie.I have just tried the latest kernel. I'll see how that goes. – sprocketoctopus Jul 14 '16 at 23:43
  • Tried latest stable kernel - still same – sprocketoctopus Jul 18 '16 at 4:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.