1

I'm unable to install unity-webapps after upgrading to 16.04. All began as tweak unity was not launching. Now i'm unable to install it from synaptic package manager also as its indicating broken packages. Help please

1

If that’s the only dependency then just type --

sudo apt install unity-webapps-service

followed by --

sudo apt install unity-webapps-common

  • Thank you for the follow up. But upon doing the above i got the following error: "The following packages have unmet dependencies: unity-webapps-service : Depends: webapp-container E: Unable to correct problems, you have held broken packages" I tried installing webapp-container using synaptics package manager, but in vain. Its prompting to fix broken packages first – Jithin G R Apr 26 '16 at 9:23
0

Steps to resolve issue

1- open terminal

2- type -- sudo apt install unity-webapps-common

3- type -- y -- to finish install

The above command should resolve your issue and allow you to install unity web apps and the corresponding dependences, this is due to the packages being replaced by unity-webapps-common.

  • When this is tried, response is:"The following packages have unmet dependencies: unity-webapps-common : Depends: unity-webapps-service (>= 2.3.8-0ubuntu3) but it is not going to be installed E: Unable to correct problems, you have held broken packages. " – Jithin G R Apr 26 '16 at 4:20
0

Finally got it solved. First had to install liboxideqt-qmlplugin; qml-module-ubuntu-web and webbrowser-app. Afterwards webapp-container could be installed. Finally unity-webapps-common and unity-webapps-service could be installed. All done using synaptics package manager. Once again thanking andy for support :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.