Just upgraded my Dell XPS13 (9350, 2016 model) to 16.04. Been trying all the things that other people seem to have with no results. Any pointers appreciated.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ sudo lshw -C sound
       description: Video
       product: Integrated_Webcam_HD
       vendor: CN09GTFM724875CHB2PFA01
       physical id: 5
       bus info: usb@1:5
       version: 56.26
       capabilities: usb-2.01
       configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
       description: Audio device
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 1f.3
       bus info: pci@0000:00:1f.3
       version: 21
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=32
       resources: irq:284 memory:dc328000-dc32bfff memory:dc300000-dc30ffff

$ cat /proc/asound/card*/codec* | grep "Codec"
Codec: Realtek ALC3246
Codec: Intel Skylake HDMI

$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

  • 2
    I have a Dell XPS 13 9333, Haswell. After upgrading 14.04 -> 16.04, I get sound out of my speakers but the headphone port is not recognized. May 2, 2016 at 20:27
  • I am also having this problem, however now I don't get sound out of my speakers either. The only sound that plays is the boot sound, but once the OS is up and running I don't get anything.
    – saarrrr
    May 29, 2016 at 18:59
  • 1
    "Any pointers appreciated" Sure — 0x3128213A, 0x6339392C, and 0x7363682E. Sorry, couldn't resist.
    – user423626
    May 31, 2016 at 14:34

3 Answers 3


My solution to all of this was to install the "PulseAudio Volume Control". This gave me the right volume knob to move the audio back up and it's been working since with the system's default audio controls.

  • slick or @bharadwaj-raju Can you specify which is the right knob? I have the exact same problem since yesterday and have installed PulseAudio Volume Control (pavucontrol) but no success, HDMI is still the only output I can send audio to in sound settings.
    – CHolmstedt
    Jul 15, 2016 at 9:45

I never got the pulseaudio fix working as listed above in the accepted answer, so after a few hours trying to fix the problem I ended up doing a clean install of Ubuntu 16.04. Wifi and sound works out of the box with a standard Ubuntu image on my XPS 13 Developer Edition 9350 (2016 model). I'm currently running following kernel after a dist-upgrade:

Linux <name> 4.4.0-31-generic #50-Ubuntu SMP Wed Jul 13 00:07:12 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
  • Did you open a ticket on Launchpad or Dell? I'm having the same issue. I upgraded from trusty to xenial without issue, but after I resumed my laptop from suspension, sound is not working t all. It only recognizes HDMI sound device.
    – clvx
    Sep 30, 2016 at 0:03
  • @clvx no, but your issue might be more related to this thread askubuntu.com/questions/759994/…
    – CHolmstedt
    Oct 1, 2016 at 15:29
  • thanks, but I reinstalled the whole system to Xenial and it's working fine now. When I mean fine, it works everything on it. I also have a WD15 dock station, and it works smoothly; though, I haven't tested the vga port.
    – clvx
    Oct 2, 2016 at 20:18
  • Never experienced the issue in my first install. Re-installed for other reasons. Audio worked for a while. Gone now :-( There's a Dell support thread: en.community.dell.com/techcenter/os-applications/f/4613/t/…
    – cuihtlauac
    Jan 28, 2017 at 1:42


options snd_hda_intel index=1,0

in /etc/modprobe/alsa-base.conf and a reboot solved it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.