I'm new to linux systems in general (I'm using Ubuntu 16.04 LTS) and I'm having difficulty in changing the brightness of my notebook.

When I use the Fn+F8 or Fn+F9 the brightness bar shows up but there is no change in the actual brightness of the screen.

I tried every method discribed in this post (How to adjust screen brightness in Ubuntu 14.04 (Trusty Tahr)?) to no success. Installing and using the xbacklight has no effect, same for editing the brightness file in the "intel_backlight" file.

Anyone knows how to solve this?

  • 1
    I had the same problem using Toshiba C660 satelite a few years back. It wouldn't work, until I used the nvidia driver from the "additional drivers" tab, couldn't get it to fix, using the open-source driver. Does it happen to you, which driver are you using? – Mookey Apr 26 '16 at 6:30
  • I think you should add at least the model name – lrkwz Apr 26 '16 at 6:36
  • 1
    The graphics card is an Intel® HD Graphics 3000. I'm still not very familiar with the way linux handles the computer drivers and all, so I'm not sure what do you mean about "additional drivers tab". – Andrei Apr 26 '16 at 17:33
  • I found a strange workaround on my laptop (compaq cq70). Instead of pressing Fn+f7 to dim and Fn+f8 to brighten, I am able to use Ctrl+f10 to dim and press Ctrl+f11 to brighten. – Joel Sjögren Jul 24 '16 at 11:32
up vote 55 down vote accepted

This does not make your brightness function keys work, but is a workround.

Install Brightness Controller with the following commands:

sudo add-apt-repository ppa:apandada1/brightness-controller
sudo apt update

For Version 1 with up to 4 Monitor Support:

sudo apt install brightness-controller-simple

]([![Brightness Controller Version 1

For Version 2 with Multi Monitor Support and other features:

sudo apt install brightness-controller

enter image description here Note: This does not decrease the intensity of backlight, so won't save your batteries. But you can use this as a last resort to save your eyes. This also works in desktops, where there is no option to control brightness.

  • 1
    This worked for me, thanks! – Andrei Apr 26 '16 at 20:01
  • 11
    This not a brigthness controller. This just play with colors of system – Harshit Chaudhary May 5 '16 at 18:59
  • 1
    @HarshitChaudhary you are right..this is a bug with this version.Thanks! – goonerDroid May 12 '16 at 16:38
  • 1
    Refer this link for more details bugs.launchpad.net/hundredpapercuts/+bug/1270579 – goonerDroid May 12 '16 at 16:44
  • 1
    @JasoonS You don't have access to secondary brightness as your computer is connected to only one monitor. – Archisman Panigrahi Jun 20 '16 at 16:24

Hardware brightness buttons 🔅 🔆

Before Ubuntu LTS 16.04

Under (X)Ubuntu 14.04 LTS, brightness control on my Panasonic Toughbook CF-52 used to work fine by adding acpi_osi=Linux to the GRUB_CMDLINE_LINUX_DEFAULT= line in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

and issuing

$ sudo update-grub

after editing and before rebooting.

Since Ubuntu LTS 16.04

However, above solution stopped working after upgrading to (X)Ubuntu LTS 16.04. This appears to be typical for laptops with integrated Intel video graphics.

To find out if you have integrated Intel video graphics, enter the following command:

$ ls /sys/class/backlight/
    intel_backlight  panasonic

At least intel_backlight should be mentioned, most probably in addition to an OEM name like for example panasonic, dell_backlight, etc.

If this is the case, proceed with creating the following file

$ sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

containing the following lines:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

Reboot, and enjoy your backlight buttons! [Source]

Finer-grained brightness control

If brightness control happens to be too coarse, then make this additional adjustment.

  • 2
    I tried this fix on my laptop which has an integrated Intel gfx card (with a backlight as revealed by the ls command as suggested), and with 2nd Nvidia 960M as well. On reboot I get a purple screen, but nothing else being displayed - I can change the background brightness, but I can't log in, as I can't see anything on the screen except a full screen purple wash. – Tony Suffolk 66 Jan 27 '17 at 11:31
  • 1
    Solved my issue with Lenovo W520 @ Ubuntu 16.04. – Igor Pomaranskiy Mar 25 '17 at 11:10
  • 1
    This answers even works for me!!!. I am Linux mit xfce user.thanks alot Gin Gordon – noone Jul 22 '17 at 8:48
  • 1
    Fixed issue on 17.04 Ubuntu as well, fn keys now work again to control brightness. – Michael Jackson Sep 27 '17 at 13:36
  • 1
    The post-16.04 version also works on Debian Stretch – Jonathan Landrum Jan 22 at 3:20

Another option is the application Redshift, which in addition to adjusting brightness can also adjust the color temperature to reduce the blue light at night.

Example usage: redshift -b 0.8 will set the brightness to 0.8 on a scale of 0 to 1

  • When using redshift, I get the problem of multiple commands being stacked, causing the screen to flicker. If i close my terminal, redshift stops working – fastenedrex Apr 14 '17 at 16:21
  • It's simple and effective.. Thanks – Giri Annamalai M Feb 17 at 16:53

I use Lenovo Z570 and adding acpi_backlight=none to /etc/default/grub and updating grub worked nicely with Fn key.

In 16.04 there is a package in the repos called "backlight-indicator" which will use your camera to set backlight (or not) and differentially set it for AC and/or battery usage.

I fixed this on my Asus UX303UB with a little difference:

  • set to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=" (acpi_osi= did it for me, other options didn't work, got this from here). Of course after this run update-grub. This make function keys respond showing the Ubuntu notification, but doesn't really change brightness. One more thing taken from other answers:
  • sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

with contents:

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"
EndSection

Now the only problem is to associate Fn+F7 to xset dpms force standby to turn off the screen.

  • 1
    Didn't work for me. I got black screen after login. – Jordan Silva Mar 26 '17 at 19:31
  • 1
    This command spoiled my system. Got stuck during booting. Don't try this. – sv_jan5 Jul 3 '17 at 4:23
  • @sv_jan5 @JordanSilva Strange, do you have 16.04.02? Exactly Asus UX303UB? Check with lsb_release -a and sudo dmidecode -t baseboard. – Pablo Bianchi Jul 3 '17 at 12:51
  • lsb_release -a gave: No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 16.04.2 LTS Release: 16.04 Codename: xenial – sv_jan5 Jul 3 '17 at 14:33

In my case, the problem was because of some issue with my graphics drivers. Changing them to a stable version solved the issue.

In XFCE, you must enable "Handle display brightness keys" on XFCE Power Manager, under the General tab.

enter image description here

protected by Community May 30 '16 at 11:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.