4

After a fresh install i can't get the shared folder to mount in /mnt/hgfs. I created the hgfs directory, purged the "open-vm-tools-dkms" and reinstalled "öpen-vm-tools" as i found somewhere else. But it doesn't seem to work.

I see there is a "vmware-vmblock-fuse" process running but /proc/filesystems does show me that "vmhgfs" is not in the kernel.

2 Answers 2

5

Ok i found the solution just after posting this question. This for lines did it for me, now lets see if it works stable (hasn't always been the case for hgfs in the past)

$ sudo apt-get install git
$ git clone https://github.com/rasa/vmware-tools-patches.git
$ cd vmware-tools-patches
$ sudo ./patched-open-vm-tools.sh
3
  • Not work for me. Instead, the following line fixed this on ubuntu 16.04. vmhgfs-fuse /path/to/created/guest/folder See superuser.com/questions/1072317
    – Farley
    Aug 12, 2016 at 17:17
  • This is a solution for zesty 17.4, thank you! May 11, 2017 at 12:27
  • Not to forgot to 'apt-get update' at the first place Jul 7, 2018 at 5:44
0

My howto on server Poweredge Centos 6 with VMWare Workstation 11.1.0 build-2496824

manipulation to show my sharing folder on VM :

Linux debian 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u5 (2018-09-30) x86_64 GNU/Linux

$ sudo apt-get update
$ sudo apt-get install git fuse
$ git clone https://github.com/rasa/vmware-tools-patches.git
$ cd vmware-tools-patches
$ sudo ./patched-open-vm-tools.sh
$ cd vmware-tools-patches (you see user@debian:~/vmware-tools-patches/vmware-tools-patches$)
$ cd vmware-tools-distrib
$ sudo ./vmware-install.pl

and choice default options from wizard

these steps fix my sharing folder from Centos to Debian VM thanks @Lothars Reloaded Scholz :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .