4

I have Ubuntu 16.04 installed under Hyper-V Generation 2 VM with secure boot disabled. (Installed from mini.iso, if that matters. x86_64)

I found that there was a problem long ago (14.04) about fixed small screen resolution.

I tried the fix proposed in various thread, namely, added a line to /etc/default/grub, saying:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=hyperv_fb:1680x1050"

I also installed linux-image-extra-virtual.

And indeed, dmesg shows that this command line is indeed passed to the kernel. (Cannot copy it because of the non-working copy-paste buffer between host and guest.)

The module, however, is not loaded (after boot, lsmod shows no sign of hyperv_fb).

Also, loading hyperv_fb manually doesn't change the screen resolution.

Any suggestions?

  • Did you execute "sudo update-grub" and restart? – Esteban Villalobos Jun 13 '16 at 18:43
  • Esteban Villalobos said: 'Did you execute "sudo update-grub" and restart?' – MadMike Jun 13 '16 at 19:02
  • 2
    Of course I did. – Vladimir Nikishkin Jun 14 '16 at 11:16
  • I am having the same problem. Loaded Ubuntu 16.04 on a Hyper-V with Gen 2, no hyperv_fb. Edit: found this bugs.launchpad.net/ubuntu/+source/linux/+bug/1287398 which basically says there is a bug in the kernel, but at the end it says it should have been fixed. – Eric Jul 26 '16 at 16:11
1

I was facing the same problem. It turns out, the solution which is adding kernel arguments in /etc/default/grub didn't work because I was using RemoteFX 3D Video Adapter in my Ubuntu virtual machine. After I removed it, the display resolution from kernel arguments started to work.

Go to your VM Settings (make sure VM is turned off), click "RemoteFX Video Adapter" under Hardware, click Remove button. Also, I disabled my dedicated graphics adapter in my computer's host OS and use only integrated Intel one (don't know if this matters).

| improve this answer | |
  • With latest Hyper-V and Ubuntu 16.04.3 64 bit the kernel parameter works fine, even with RemoteFX enabled in Hyper-V. – fviktor Oct 24 '17 at 21:39
  • If you remove RemoteFX, you lose all 2d hardware acceleration and the screen update speed falls below what most users can tolerate. Also @fviktor as of Aug 2018 hyper-v and ubuntu18 there is no support for anything other than 1024x768 with RemoteFX enabled. – fret Aug 14 '18 at 4:46
  • Since then I moved away from using any GUI on Linux VMs. The remote deloyment mode of IDEs usually works best for development. Xming [ sourceforge.net/projects/xming ] is a reasonably fast solution if the GUI application must absolutely run on Linux. It works well even at higher than HD resolutions. – fviktor Aug 18 '18 at 14:29
  • This works for me - removing the RemoteFX VideoAdapter. Thanks – stuzor Jun 17 '19 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.