I'm trying to set up a wireless scanning server. I'm following this guide https://help.ubuntu.com/community/SaneDaemonTutorial but I'm having issues at the time to run sudo service saned restart where I get

Failed to start saned.service: Unit saned.service is masked.

I have even tried to do systemctl unmask saned.service && systemctl start saned.servicebut I stills echoes the same error.


  • Same probkem I am running 16.04 64bit and cannot unmask saned service either. Commented Apr 26, 2016 at 15:28

2 Answers 2


I am not expert about systemd internal workings, but I was able to connect to scanner in this setup:

computer_A  ---network--->  computer_B with SANE  ---USB---  scanner

after running this (on computer_B):

sudo systemctl start saned.socket

It is probably the right way of doing it, judging by description here: - https://unix.stackexchange.com/questions/159462/what-is-systemds-target-service-and-socket

And to make it start automatically on startup:

sudo systemctl enable saned.socket
  • I was trying to get a PDF scanning program that depends on saned to work. This allowed the program to find the scanner. Thank you! Commented May 13, 2016 at 15:25
  • That's not what a network scanner means. A network scanner stands alone for scanning service.
    – funicorn
    Commented Jan 12, 2018 at 7:00

I copy some answers from this page: https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1577137

Post number 13:

I just received some updates:

libudev1 (229-4ubuntu5) to 229-4ubuntu6
libudev1:i386 (229-4ubuntu5) to 229-4ubuntu6
python3-urllib3 (1.13.1-2) to 1.13.1-2ubuntu0.16.04.1
systemd (229-4ubuntu5) to 229-4ubuntu6
systemd-sysv (229-4ubuntu5) to 229-4ubuntu6
udev (229-4ubuntu5) to 229-4ubuntu6

Xsane just works fine now (without any configuration). It might be that the two extra config-files in /etc/systemd/system (saned.socket and [email protected]) are still needed. So I will do some more testing before celebrating :)

And post number 18:

While the systemd related updates fixed sane again as I could find the pixma scanner again... However, it turned out to be a scanner from the office downstairs (lol, saves me some electricity but I am not sure whether they would be happy with that ;) ).

To find my own scanner (pixma MG5700 series) I had to upgrade to sane-backends-1.0.26 (from 1.0.25). I added a ppa to my sources.list to do this the easy way:
deb http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu xenial main
This version works like a charm.

Anyway, I am clueless about what the systemd fixed but it did it.

It might be useful to read all the posts because that will explain why I initially added saned.socket to /etc/systemd/system but this is no longer needed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .