4

I've recently upgraded from Xubuntu 15.10 to 16.04 and I've noticed that some windows have shadows and some don't (I don't want them). I'm using compton as my compositor with the following shadow related settings in my ~/.compton.conf:

shadow = false;
no-dnd-shadow = true;
no-dock-shadow = true;
clear-shadow = true;
shadow-radius = 1;
shadow-offset-x = -1;
shadow-offset-y = -1;
shadow-opacity = 0.1;

I assume shadow = false; is enough to disable them, the other settings are there as part of my trial and error to see if I could affect the remaining shadows.

The shadows that remain look like this: Shadows on indicator plugin

They also appear on the Skype and networking context menus, but not on any of the others, including the calendar and user switcher.

In addition to the panel, I'm also getting a shadow on the calculator application, but not on any others that I have tested…

Are these being rendered by compton, or is there something else going on here? If I kill compton, those shadows are replaced with a big block of black, as seen here on the calculator, but this also happens with the indicators in my panel, too:

With and without compton running

7

For default Xfce compositor

Go to Settings -> Windows Manager Tweaks. Choose the tab Compositor and uncheck the option Show shadow under regular windows.

For compton compositor

Add the following lines to wintypes setting in ~/.config/compton.conf

dropdown_menu = { shadow = false; };
popup_menu    = { shadow = false; };

Example:

wintypes:
{
    ## To disable shadows for menus
    # menu        = { shadow = false; };
    dropdown_menu = { shadow = false; };
    popup_menu    = { shadow = false; };
    # utility     = { shadow = false; };
};

Hope you success!

An example for compton.conf in git.archlinux.org

  • I believe this interface is for configuring the default xfce compositor; I have "Enable display compositing" un-ticked here (but "Show shadows under regular windows" is disabled, anyway). – Kris Oct 29 '16 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.