2

I have backed up the contents of the directory "VirtualBox VMs" and now I am trying to restore the states of my virtual machines by copying the backed up files, back.

Now when I select "Machine" -> "Add" and select the qcow file of my VM, I receive the following error:

VirtualBox error

I have tried running

vboxmanage internalcommands sethduuid "home/user/VirtualBox VMs/ubuntu32-alt-text/ubuntu32-alt-text.qcow"

but I'm getting the following error:

`VBoxManage: error: Cannot set a new UUID: VERR_NOT_SUPPORTED`

How do I properly restore a Virtualbox VM?

I'm runnung VirtualBox 5.0 on Ubuntu 16.04 (amd64).

  • What version was it made with? – Tim May 1 '16 at 23:49
  • The same one, 5.0.18. It's actually the same computer with the same installation of VirtualBox; I'm doing a test run of backing up and restoring VMs to make sure it works for me. – Nickolai Leschov May 4 '16 at 7:07
  • How did you back it up? – Tim May 4 '16 at 9:37
1

Hi Nickolai I found the same suggestion and got the same result as you:

vboxmanage internalcommands sethduuid gave

Cannot set a new UUID: VERR_NOT_SUPPORTED

If we're restoring a VM, we should first remove the original and its media from inventory.

Select the VM then use Machine -> Remove from the menu. After that select Remove only option if we want to preserve the original VM's files.

After removing the original, there will be no UUID conflict. Then we can use Machine -> Add and selected the .vbox file of the restored VM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.