0

I have an Asus N55S notebook with Nvidia Gefore GT555M and an external Samsung monitor connected via HDMI. With the proprietary Nvidia driver dual display mode was working perfectly in Ubuntu Gnome 15.10 but after the upgrade to 16.04, the built-in notebook display is not detected anymore. The Gnome display settings as well as the Nvidia X server settings only show the external Samsung monitor. When I disconnect the external monitor, the built-in notebook display stays black and I get no display at all. Nvidia driver version is 361.42.

monitors.xml:

<monitors version="1">
  <configuration>
    <clone>no</clone>
    <output name="HDMI-0">
      <vendor>SAM</vendor>
      <product>SMBX2431</product>
      <serial>0x42324347</serial>
      <width>1920</width>
      <height>1080</height>
      <rate>60</rate>
      <x>1920</x>
      <y>0</y>
      <rotation>normal</rotation>
      <reflect_x>no</reflect_x>
      <reflect_y>no</reflect_y>
      <primary>yes</primary>
      <presentation>no</presentation>
      <underscanning>no</underscanning>
    </output>
    <output name="LVDS-1-0">
      <vendor>SEC</vendor>
      <product>0x314c</product>
      <serial>0x00000000</serial>
      <width>1920</width>
      <height>1080</height>
      <rate>59.998786926269531</rate>
      <x>0</x>
      <y>0</y>
      <rotation>normal</rotation>
      <reflect_x>no</reflect_x>
      <reflect_y>no</reflect_y>
      <primary>no</primary>
      <presentation>no</presentation>
      <underscanning>no</underscanning>
    </output>
  </configuration>
</monitors>

xorg.conf:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection
0

I was able to solve this problem with the 364.19 driver from the graphics drivers ppa:

  1. Remove current Nvidia driver: sudo apt-get purge nvidia-*
  2. Add graphics-drivers PPA: sudo add-apt-repository ppa:graphics-drivers/ppa
  3. Update the package lists: sudo apt-get update
  4. Install 364.19 driver from "Additional Drivers" tab in the "Software & Updates" application

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.