13

I recently upgraded from Ubuntu 14.04 LTS to Ubuntu 16.04 LTS. Had a few issues with phpmyadmin and MySQL-Server that I rectified. But whenever I restart the system, I lose internet connection. Although, WiFi is showing to be enabled, when seen in System Settings > Networks, it shows that all routers are out of range.

I tried stopping and then restarting WiFi using the WiFi button on my laptop. But it didn't work.

I also tried doing it from terminal as given in this answer. It also didn't work. Command as follows:

sudo service network-manager restart

Also, tried this answer. It didn't work either. Command as follows:

sudo systemctl restart NetworkManager.service

Output of sudo lshw -class network is as follows:

*-network               
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: eth0
       version: 07
       serial: 14:58:d0:c1:1e:d0
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:58 ioport:3000(size=256) memory:b2600000-b2600fff memory:b2400000-b2403fff
  *-network
       description: Wireless interface
       product: RT3290 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: wlan0
       version: 00
       serial: b0:10:41:7f:5c:b5
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=3.13.0-77-generic firmware=0.37 ip=192.168.1.102 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:b2510000-b251ffff
  • 4
    Have you tried usign only the live USB or DVD media, to chek if booting with it also makes the WiFi to fail?. If this happens, you could have a hardware issue. Otherwise, I recommend you to do a fresh install of your Ubuntu. I have always had problems with upgrades. Always (in my case) is better to do a fresh install. Regards. – GTRONICK Oct 31 '16 at 19:22
  • 3
    I don't understand this: ...But whenever I restart the system, I lose internet connection..... Does it mean that sometimes you DO have WiFi? Or you havn't any WiFi connection since you had updated your OS? – Rostislav Kandilarov Nov 8 '16 at 15:29
  • 2
    Could you add the output of rfkill list when this happen. – user.dz Nov 24 '16 at 0:03
  • Run dmesg in a terminal and press the wireless buttons it should output an error in that log that describes what is happening. – Kristopher Ives Nov 27 '16 at 14:40
  • remove the driver once and try installing it again as i faced the same issue with the upgrade – vembutech Dec 8 '16 at 17:29

Browse other questions tagged or ask your own question.