5

I have a windows storage space setup on my windows 10 instalation. The storage space includes only a single NTFS drive (sdb) and the drive is only used for storing media, windows is installed on a separate ssd (sda) and so is ubuntu (sdc).

Previously I had to disable quick startup on windows in order for ubuntu to be able to read the files in my windows drive (sda). In this case ubuntu doesn't even detect my media drive.

Is there any way in which I can read and write from my media drive from ubuntu gnome or linux in general?

Update:

I can see the drive by using lsblk:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 111,8G  0 disk 
├─sda1   8:1    0   350M  0 part 
├─sda2   8:2    0   111G  0 part /media/myusername/F04C0DC34C0D8616
└─sda3   8:3    0   450M  0 part 
sdb      8:16   0   2,7T  0 disk 
├─sdb1   8:17   0   128M  0 part 
└─sdb2   8:18   0   2,7T  0 part 
sdc      8:32   0 223,6G  0 disk 
├─sdc1   8:33   0     1K  0 part 
├─sdc2   8:34   0 214,7G  0 part /
└─sdc5   8:37   0   8,9G  0 part [SWAP]

I'm trying to read sdb/sdb2.

When I use sudo mount /dev/sdb2 /media/myusername/mediadrive

I get:

wrong fs type, bad option, bad superblock on /dev/sdb2,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

When I execute sudo parted -l the output is:

Model: ATA Samsung SSD 840 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  368MB  367MB  primary  ntfs         boot
 2      368MB   120GB  119GB  primary  ntfs
 3      120GB   120GB  472MB  primary  ntfs         diag


Model: ATA ST3000DM001-1CH1 (scsi)
Disk /dev/sdb: 3001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      17,4kB  134MB   134MB                Microsoft reserved partition  msftres
 2      135MB   3001GB  3000GB               Grupo de almacenamiento


Model: ATA KINGSTON SV300S3 (scsi)
Disk /dev/sdc: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type      File system     Flags
 2      1049kB  231GB  231GB   primary   ext4            boot
 1      231GB   240GB  9499MB  extended
 5      231GB   240GB  9499MB  logical   linux-swap(v1)
13
  • How is it formatted? NFTS / FAT? Is it directly connected?
    – Tim
    Apr 25, 2016 at 15:59
  • @Tim nfts. It's an internal drive and its directly connected.
    – 0x6C38
    Apr 25, 2016 at 16:00
  • @MrD I add screen-shot. See in below. Apr 25, 2016 at 17:02
  • @MrD Give me answer this command : echo $USER Apr 25, 2016 at 17:13
  • @k-five I'd rather not, the computer isn't mine. You can assume its myusername tho
    – 0x6C38
    Apr 25, 2016 at 17:19

4 Answers 4

4

Storage Spaces are based on a new proprietary file system from Microsoft called ReFS (resilient file system)

At the time of writing, there is no Open Source software that allows to mount this kind of file system, the only option right now is to use proprietary software:

ReFS for Linux by Paragon Software

Note: I am not affiliated with Paragon Software in any way, I am just stating the facts.

3

Yes :

sudo mount /dev/sdb2 /media/myusername/mount-point

OR

sudo mount /dev/sdb2 /media/$USER/mount-point

First use this command to show your hard lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 931.5G  0 disk
├─sda1   8:1    0   100G  0 part /media/shu/temp
├─sda2   8:2    0     1K  0 part
├─sda3   8:3    0 190.8G  0 part /
├─sda4   8:4    0 638.9G  0 part
└─sda5   8:5    0   1.9G  0 part [SWAP]
sdb      8:16   0   1.8T  0 disk
├─sdb1   8:17   0   128M  0 part
├─sdb2   8:18   0 931.5G  0 part
└─sdb3   8:19   0 931.5G  0 part /media/shu/movie

then go to /media/$USER

Notice : $USER = your username. For Example my username name is shu

and create one mount point

Such as cd /media/shu

thensudo mkdir windrive

then if you have ntfs use sudo mount /dev/sda1 /media/$USER/anyname

but if you have fat32 use sudo mount -t vfat /dev/sda4 /media/$USER/fat32 -o uid=1000,gid=1000,umask=022


Sample : I want to mount sdb3

enter image description here

Because I already mounted sdb3 give me an error, but for you work.

  1. lsblk

  2. cd /media/shu # your username

  3. sudo mkdir mount-point

  4. sudo mount /dev/sdb3 /media/shu/mount-point

6
  • what's /dev/ in the mount command? I'm getting mount: special device /dev/sdb2/ does not exist (a path prefix is not a directory)
    – 0x6C38
    Apr 25, 2016 at 16:42
  • When I use lsblk I can see that I want to mount (sdb/sdb2). If I replace dev for sdb I get mount: special device /sdb/sdb2/ does not exist instead.
    – 0x6C38
    Apr 25, 2016 at 16:48
  • @MrD /dev/ is a path to mount the partition. And /media/shu/mount-point is a path to load your files. Apr 25, 2016 at 16:54
  • @MrD Did you format it ? I mean sdb2 that is 2.7T !!! Apr 25, 2016 at 17:10
  • 1
    Just a small thing, but /media is meant for detachable storage, like USB sticks, SD cards, and the like. /mnt is meant for permanently attached storage, like internal HDD's, SSD's, etc... It won't make any difference which you use, and is purely organisational, but it's considered good practice to keep things separated like that, and it's a good habit to get in to. Who knows, one day you might work looking after a server farm, and struggle to get out of the bad habits you adopted years ago.
    – Jack_Hu
    Apr 8, 2020 at 12:05
2

You probably cannot read the Windows Storage Space using any current tools in Linux. It's not a matter of detecting and mounting it, it's a matter of reading Microsoft's proprietary virtual file system. It is a similar problem as if you had a LVM2 volume which you are trying to open from Windows, you can see it's there, but reading it is another matter. Also, because you don't know how it works, I highly recommend not mounting it or otherwise poking it; especially if this isn't your computer.

0

Type

sudo mount /dev/sdb2 /media/winfiles

not "mount /sdb/sdb2" and not "mount /dev/sdb2/"(sdb2 is treated as a file not a directory).

If this gives you an error, sdb2 doesn't exist or anything, type

cd /dev
ls

and check if a file named sdb2 is in the folder "/dev"

3
  • There is a file sdb2 in the /dev folder
    – 0x6C38
    Apr 25, 2016 at 17:15
  • Then try the command "sudo mount /dev/sdb2 /media/winfiles" and see if it works. Apr 25, 2016 at 17:16
  • I did, output is in the updated answer
    – 0x6C38
    Apr 25, 2016 at 17:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .