I recently moved to Ubuntu 16.04 LTS and I noticed that VidyoDesktop was no longer available on my system. I tried to install it from the deb package using dpkg but I received the following error:

$ sudo dpkg -i VidyoDesktopInstaller-ubuntu64-TAG_VD_3_6_3_017.deb 
dpkg: problemi con le dipendenze impediscono la configurazione di vidyodesktop:
 vidyodesktop dipende da libqt4-gui (>= 4.8.1); comunque:
  libqt4-gui not installed.

I've noticed that libqt4-gui is not present in Ubuntu 16.04 repository. Does anyone know how to fix this? Thank you

Edit: My question is different from "How to install a deb file with dpkg". In fact I was asking how to install a specific package with a missing dependance.


As the following link by Vidyo suggests,


one just needs to eliminate dependency on libqt4-gui (again, this case is already mentioned in previous answers but this is yet another approach.)

If I may, let me copy the solution from the above link and paste it here. I just made changes in the 3rd and 4th steps where I mention using vim editor instead of nano.

1) Download the VidyoDesktop .deb file to your home directory

2) Run the following commands from the terminal (replacing "vidyodesktop.deb" with the exact filename according to your system type)

$ cd ~
$ dpkg-deb -x vidyodesktop.deb vidyobuild
$ dpkg-deb --control vidyodesktop.deb vidyobuild/DEBIAN

3) Edit the package control file

$ vim vidyobuild/DEBIAN/control

Replace the entire Depends: line by copying and pasting the following:

Depends: libxss1,libaudio2,libasound2,libqt4-network

This removes the libqt4-gui transitional package dependency which is no longer required for recent Ubuntu versions

4) Save the customized .deb file




$ dpkg-deb -b vidyobuild vidyodesktop-custom.deb

5) Install the new VidyoDesktop .deb file by running

$ sudo dpkg -i vidyodesktop-custom.deb

[EDIT: Vidyo desktop works only in wifi mode. If the LAN cable is connected, then Vidyo shuts down. I haven't found a solution to this problem yet. But rest is working!]

  • 1
    In addition to this, I found that in order to avoid seg faults: /usr/bin/VidyoDesktop: line 6: 3085 Segmentation fault (core dumped) /opt/vidyo/VidyoDesktop/$EXEC $option $audioflag $@ one needs to enable the "always use VidyoProxy" in the options. – Andrea Borga Jan 11 '18 at 10:00
  • 2
    @AndreaBorga How do you go about enabling that option if VidyoDesktop won't launch due to the segfaults? – gene_wood Jul 17 '18 at 16:31
  • 1
    @gene_wood mine was seg faulting when joining a meeting. – Andrea Borga Aug 5 '18 at 8:04

The solution provided by Andrea works, but I'd like to report the exact command:

 sudo dpkg -i --ignore-depends=libqt4-gui VidyoDesktopInstaller-ubuntu64-TAG_VD_3_6_3_017.deb 
  • This works but Ubuntu's software center will complain and annoy you with warnings about broken packages due to missing dependencies (the one you chose to ignore). – fuenfundachtzig Jan 28 '18 at 14:47
  • with above solution vidyo got installed but it is not starting up – Nitin Mar 16 at 4:38

My workaround has been to build a dummy libqt4-gui transitional package, using a control file based on the qt4-x11 source package and the equivs tools:

sudo apt install equivs
wget http://fwyzard.web.cern.ch/fwyzard/ubuntu/libqt4-gui/control
equivs-build control
sudo dpkg -i libqt4-gui_4.8.7_amd64.deb
sudo apt install -f
  • This worked for me. But I had to install some other packages first: apt install libqt4-designer libqt4-svg – Edward van Kuik Dec 13 '16 at 14:17
  • Please change the accepted answer to @fwyzard's reply. The currently accepted answer is only relevant to CERN users. – Reece Jan 9 '17 at 21:12

I had the same problem. I solved by forcing install without checking dependencies (google for the exact dpkg command). You will still have a formally broken package on your system, but apparently VidyoDesktop works smoothly also without libqt4-gui...

Does anybody know why the package was dropped? I suspect this will create problems to several 3rd party packages...

  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Apr 28 '16 at 15:27

Have a look here for a modified VidyoDesktop installer without the dependency on libqt4-gui:


NOTE: This link is no longer publicly visible, and may not provide useful information anymore.

Please note that it is a CERN protected page, so I prefer not to post the full link here, since the VidyoDesktop package is not free software


I suggest to manually download libqt4-gui and its following dependent packages from URL.

  1. libqt4-designer
  2. libqt4-opengl
  3. libqt4-svg
  4. libqtgui4
  • The command you suggested results in disinstalling vidyodesktop – Matteo S. Apr 25 '16 at 15:48
  • @K.K Patel, this will not work, as the package "libqt4-gui" is not available in the 16.04 repositories. – blendenzo Apr 25 '16 at 16:02
  • Yep, same problem here, but installing open365 deb package. Looks like libqt4 has been removed from ubuntu 16.04 – Jorge Arévalo Apr 26 '16 at 6:54
  • @Matteo S. Please check it now. I edited answer. – Ketan Patel Apr 26 '16 at 12:58
  • the solution proposed by @MatteoS. is more effective and avoids fiddling around with officially discontinued libraries. – Andrea Borga Jan 11 '18 at 10:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.