5

Okay I think I need some help with my on-board audio device and Ubuntu 16.04.

My on-board Audio device according to sudo lspci is:

*Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)*

aplay -l prints:

    **** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

It used to work fine with Ubuntu 12.04 and 14.04 but not with the current lts version 16.04. I get no sound at all and it doesn't even show up in the "sound settings tab" so maybe it's a driver gone wrong issue with 16.04?

I tried every single suggested solution from older posts but still no luck. Any ideas?

Desktop System Specs:

  • Intel Core i3 540 @ 3.07GHz
  • 8.00GB DDR3
  • ASUSTeK Computer INC. P7H55-M PRO (LGA1156)
  • 1024MB ATI AMD Radeon R7 200 Series

Input Output & Terminal

  • It's been a month and still no official solution by Canonical. This is just ridiculous! – John E.K. Jun 3 '16 at 16:24
5

The issue is that Ubuntu 16.04 defaults to HDMI as default audio if HDMI is present on your computer. In my case, it does see my Sound Blaster Audigy 2 card, but HDMI (from my video cards) is set as default; and the way to change that differs from how you did that in 14.04.

The files, folders and procedures almost work, but don't if you follow 14.04's "No Sound" issues because file names and locations have changed in 16.04. I get this information from a week of Googling and experimenting. But it appears that it is a known bug so an answer should be coming soon. In the mean time, I guess we both have to wait. When I need sound, I revert to a 14.04 netbook. Netbooks can't meet the system requirements of 16.04, but more than meet 14.04's requirements. That should say something.

Although I don't have an answer for you, I hope this gives you some insight into the issue we are having. If you come up with something, let me know. Thanks,

| improve this answer | |
  • Thanks for the input Jef! Good to know it's a known bug. The funny thing is that the os can see my external usb audio (that for most people isn't working without removing fwupd) and simply ignores the on-board audio. – John E.K. May 13 '16 at 7:40
5

Don't know if you are still having issues with this, I experienced a similar problem on my mini PC. It also has the Intel Wildcat audio device; I managed to fix it by doing the following:

  • Install pavucontrol (PulseAudio Volume Control); it's available on the software centre as well
  • On the "Configuration" tab, check if you have 2 profiles
  • Set the profile you don't need to "Off". In my case it was the one with a whole lot of analogue options

Once I did this, all the weird behaviour stopped and my audio was working on all applications (I was specifically interested in Kodi, however Rythmbox, VLC and Videos also started working). I've now got fully functional 5.1 surround. Strangely, youtube streaming on Firefox had audio before the change (and after of course :) ).

Hope this helps.

| improve this answer | |
  • 1
    This helped me. I had "Port" dropdown with two options: "linear output" and "analog headphones". I selected analog headphones (for frontal headphones output) and the sound was restored. – Semyon Danilov Feb 17 '17 at 14:31
4

I was having this exact same issue after upgrading to 16.04 with my Focusrite Saffire 2i4, I finally found this and fixed it with this command, then rebooting:

sudo apt-get remove fwupd

You probably don't want to do that if you actually need fwupd, but it looks like there's already a bug report out there, hopefully it will get fixed soon.

| improve this answer | |
  • That didn't help either. I should probably switch back to 14.04 until 16.04 is stable enough. Too bad. – John E.K. May 6 '16 at 15:54
  • After reading the bug report: It's not the external usb device that troubles me. That works flawlessly. It's the on-board audio unit that is not showing up on the sound settings panel at all. – John E.K. May 6 '16 at 15:58
2

I have the same issue. The funny thing is that I can hear the sound of the login screen.

What I also figured out is that VLC works if I configure audio to use ALSA. That makes me think the pulsaudio stuff is broken.

After knowing that I started pulseaudio. I switched configuration, internal device, to Analog Stereo Duplex. It was configured to use Digital Stereo IEC958.

| improve this answer | |
1

I had a similar problem but I after trying many things including uninstalling and reinstalling alsa-base and pulseaudio, what finally worked is the removal of the pulse folder under the .config folder inside my home folder.

| improve this answer | |
  • Unfortunately that didn't help. Maybe I should try reinstalling alsa. I tried pulse but not alsa. -Edit: That made no difference either. – John E.K. Apr 29 '16 at 10:44
1

Funny enough for me in similar situation helps changing display resolution from 1280x720 16x9 to 800x600 4x3. HDMI sound appears in 100% cases! Then I switch resolution back, sound sometimes stays. Not for long though.

aplay -l 

    **** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC662 rev3 Analog [ALC662 rev3 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC662 rev3 Digital [ALC662 rev3 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0


lspci

    00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
| improve this answer | |
  • Not happening here :( 16.04 is by far the most unstable stable Ubuntu release ever! – John E.K. May 28 '16 at 8:19
1

Okay, it seems like Canonical fixed the problem for us with one of their latest system updates! Thanks guys!

Output

EDIT: Input is still not working (mic/line in).

Input

| improve this answer | |
  • 1
    good for you, but on my machine it didn't fix anything. :( – Christian Schmitt Aug 13 '16 at 17:34
  • Okay, not marked as fixed anymore then. I don't know if it's Linux or Ubuntu that messed this one up, but someone should take a look into it. – John E.K. Aug 14 '16 at 21:09
  • ah you can fix it. I found out that it's not a ubuntu issue and that the issue only occured at my front output. Also the output list on my side is empty but as soon as I put something in, it detects it. but not in the front. this is the bug that happened: bugzilla.kernel.org/show_bug.cgi?id=81561 fix is simple hdajackretask and remap 0x1b to headphones – Christian Schmitt Aug 14 '16 at 21:35
0

The same issue happened on my OS, Ubuntu 16.10, after an upgrade under the utilization of ALSA, Pulseaudio and an external USB Soundcard:

The following measures did not fix the malfunction:

  • Disable ACPI in GRUB Boot Options, which could lead to powered off USB Devices: acpi=off
  • Disable ACPI in BIOS
  • Configuration of Full Speed and High Speed of USB Port
  • Configuration files in /etc/asound.conf and ~/.asoundrc as documented by ALSA
  • Utilization of pavucontrol
  • Reinstallation of Pulseaudio and ALSA Utils

The main issue is the activated IDLE-Mode in the Pulseaudio Config File: /etc/pulse/default.pa that powers off the USB Soundcard.

The following procedure solved the malfunction of the USB-Soundcard:

1. Check available soundcards installed on system.

cat /proc/asound/cards

0 [NVidia ]: HDA-Intel - HDA NVidia HDA NVidia at 0xfbe78000 irq 21

1 [CI2 ]: USB-Audio - Steinberg CI2 Yamaha Corporation Steinberg CI2 at usb-0000:00:12.0-2, full speed

Index 0: Onboard Soundcard Intel. Index 1: External USB Soundcard

2. Find corresponding driver module for Onboard Soundcard:

lsmod | grep snd

Get detailed info about driver:

modinfo snd_hda_audio

Read description of driver, it should correspond to PCI Card, as discovered in first step, under category "parm".

Note: Driver "snd_usb_audio" is for USB Device soundcards and "snd_hda_audio" for Intel onboard soundcards.

3. Deactivate Onboard Soundcard Driver by blacklisting it, therefore only one audio driver can correspond to the utilized USB soundcard:

sudo nano /etc/modprobe.d/blacklist.conf

Add following line at end of file, by using the driver as eaxmined in Step 2:

blacklist snd_hda_intel

  • in my cases the kernel has not to be updated. If the device is not blacklisted in the following step 4, try to update Kernel:

sudo update-initramf -u

4. Check if blacklisting was successfull. Only the second soundcard should appear:

cat /proc/asound/cards

1 [CI2 ]: USB-Audio - Steinberg CI2 Yamaha Corporation Steinberg CI2 at usb-0000:00:12.0-2, full speed

5. Deactivate Idle Mode which is similar to suspend sode for Audio Device, otherwise the USB device disconnects automatically, when no usage by sound application:

sudo nano /etc/pulse/default.pa

Change following line:

load-module module-suspend-on-idle

to

#load-module module-suspend-on-idle

Reboot

Observation: It is recommended to install the application "pavucontrol" for additional configuration and supervising of current sound configurations.

sudo apt-get install pavucontrol

I hope this helps others as well.

| improve this answer | |
  • this one did not fix my problem. it just gave me a dummy card after blacklisting it. – Seandex Feb 29 at 8:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.