1

I am trying to install Ubuntu 14.04 in HP EliteDesk 800 G2 SFF, in which Windows 7 is also installed. While wired network connection works well on Windows, it doesn't on DVD-booted Ubuntu. Then I noticed that only IPv6 address is set:

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 48:0f:cf:41:c7:83
          inet6 addr: fe80::4a0f:cfff:fe41:c783/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:972 errors:0 dropped:0 overruns:0 frame:0
          TX packets:576 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:140475 (140.4 KB)  TX bytes:113164 (113.1 KB)
          Interrupt:16 Memory:e1000000-e1020000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:49 errors:0 dropped:0 overruns:0 frame:0
          TX packets:49 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4880 (4.8 KB)  TX bytes:4880 (4.8 KB)

I followed this instruction, but still cannot connect to wired network.

$ sudo cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto eth0
 iface eth0 inet dhcp
$ sudo service network-manager start
start: Job is already running: network-maneger
$ sudo /etc/init.d/networking restart
$ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 48:0f:cf:41:c7:83
          inet6 addr: fe80::4a0f:cfff:fe41:c783/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1776 errors:0 dropped:0 overruns:0 frame:0
          TX packets:954 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:262483 (262.4 KB)  TX bytes:187146 (187.1 KB)
          Interrupt:16 Memory:e1000000-e1020000

What should I do to connect to the network so that I can move on to the Ubuntu installation?

  • Probably your network doesn't use DHCP and you'll need to enter the settings manually (IP address, subnet mask, gateway and DNS servers). Please boot into Windows 7 and look at the network settings there. – user300458 Apr 25 '16 at 12:55
  • Are there any clues here? sudo ifdown eth0 && sudo ifup -v eth0 – chili555 Apr 25 '16 at 13:04
  • @user300458 Exactly right. I don't know much about network settings, but found that DHCP is not available with my network (actually, it's not mine but my lab's). I was manually able to set up the Ethernet connection via Network Connections app. Could you post your comment as an answer when you have time so that I can accept it? – yudai-nkt Apr 27 '16 at 12:46
  • @yudai-nkt, done :-) – user300458 Apr 27 '16 at 14:38
0

(Probably) your network doesn't use DHCP and you need to enter the settings manually (IP address, subnet mask, gateway and DNS servers).

Please boot into Windows 7 and look at the network settings there.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.