4

How can I set up my DSL connection on Ubuntu 16.04? The way I set up a DSL connection in Ubuntu 14.04 is not working in Ubuntu 16.04.

2

I solved my problem through following steps:

  1. go to terminal
  2. type sudo pppoeconf
  3. it will ask some question, press yes
  4. when you want to start internet just type sudo pon dsl-provider to connect to internet
  5. type this to turn it off sudo poff
| improve this answer | |
1

This tutorial is going to show you how to setup a PPPoE connection in Ubuntu from the terminal.

  1. Open up your terminal and type the following command to set your PPPoE connection.

    nmcli con edit type pppoe con-name “YOUR_CONNECTION_NAME”
    
  2. Enter your DSL account and password provided by your ISP and save your settings in the following commands.

    set pppoe.username YOUR_DSL_ACCOUNT_USERNAME
    set pppoe.password YOUR_DSL_ACCOUNT_PASSWORD
    save
    

    Then it will prompt asking:

    Saving the connection with ‘autoconnect=yes’. That might result in immediate activation of the connection.    
    Do you still want to save? (yes/no). 
    

    Type yes and quit.

    Setting DSL connection in terminal

  3. Finally, select DSL connection from the network settings menu to establish the connection.

    Choose DSL connection to connect
    (Click image to enlarge)

References: https://medium.com/@dineshsonachalam/creating-a-dsl-connection-on-ubuntu-18-04-1-lts-c5b7845beea0

| improve this answer | |
  • nmcli works great, but I found that, command is little different in Ubuntu 18.04 – mahfuz Sep 12 at 15:23
0

Just run sudo pppoeconf in terminal. Then give your username and password in popup windows.

| improve this answer | |
0

I was having the same problem yesterday, and I tried all the above options but this did not work. However, today, after comparing the dsl-provider file on my Ubuntu 16.04 computer with the file that has the same name on my Debian 8.8 computer, I noticed that there was an error in the Ubuntu file. So I fixed the file this way:

# Minimalistic default options file for DSL/PPPoE connections

noipdefault
defaultroute
replacedefaultroute
hide-password
#lcp-echo-interval 30
#lcp-echo-failure 4
noauth
persist
#mtu 1492
#persist
#maxfail 0
#holdoff 20
plugin rp-pppoe.so
nic-enp3s0f1
usepeerdns
user "XXXXXXX"

where XXXXXXX is my mailbox provider.

| improve this answer | |
-1

Edit the file:

$ sudo nano /etc/network/interfaces

By adding to it:

auto lo eth0 
iface lo loopback eth0 inet dhcp

After restart network-manager:

$ sudo service network-manager restart
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.