8

Just now I upgraded to 16.04 from 15.10. I had installed a newer kernel in 15.10 (I believe the 4.4.2 kernel), but the kernel of 16.04 is supposed to have working wifi with xps 13 out of the box. However, right after installing and rebooting, it seems to have lost my wifi. Is there something I have overlooked? Or better said, how to get it working again?

1
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command.
    – Pilot6
    Apr 25 '16 at 7:53
7

Found in other answers, this is how I fixed the problem: sudo lshw -C network

*-network
    (...)
    logical name: wlp58s0
    (...)

I then ran sudo ifconfig wlp58s0 up and after that sudo service network-manager restart. This fixed my wifi and after reboot it is still working.

Since the dell xps13 (9350) has had many troubles with wifi, I hope this will help others to fix theirs too.

EDIT: This only fixes it once, after reboot the same steps have to be performed again to get it back on.

1
  • 1
    lshw -C network shows a disabled network and ifconfig wlp58s0 up fails. sigh. Getting closer, just need it to work long enough to upgrade to 16.04.02
    – spazm
    Mar 6 '17 at 4:31
1

Disabling secure boot in the BIOS solved the problem for me. I found the answer on the dell forums. (http://en.community.dell.com/support-forums/laptop/f/3518/t/19683197)

0

Found this on Dell community page. And this solved the problem for me :

Go to software & Updates, enable"Proprietary drivers for devices"

Reload sources, and apt-get upgrade

It'll grab the latest broadcom drivers and intel microcode, you'll need to disable secure boot if its enabled, reboot, and it should work.

Did it on my 9343 to 16.04 with kernel 4.4.0-21-generic

0

none of this works permanently. I believe the wireless card used in the XPS is just not compatible with ubuntu 16. https://www.windowscentral.com/dell-xps-wifi-fix-upgrade-wireless

Doing a search on these issues brings quite a few pages. I feel Dell have fallen short on providing an Ubuntu compatible laptop.

I am going to change the wireless card, but if that does not work, I will have to get a mac. Changing back to ubuntu 14 is not an option, as a bunch of things are no longer supported. This is pretty substandard effort of dell, cannonical etc.

Also the problem goes away when using a different router for instance, or even more confusing only happens while using one of a range of routers, butg no other device has a problem with the router in question. When you restart network services, sometimes the network comes back good and fast for all of one minute, then stops. Signal shows good, but no network. At first I thought it was DNS, so manually set DNS servers to 8.8.8.8 and 8.8.4.4. Nope. Then I thought it may be IPV6 causing the issue, so I forced the connection to be IPV4 (This worked for Ubuntu 14). Then drivers, new drivers, old drivers no dice. Then obscure network settings regarding security. I have changed a whole heap with no Joy.

The only thing I have not tried is replacing the wireless card. That is next.

2
  • try echo 'SUSPEND_MODULES="brcmfmac"' | sudo tee -a /etc/pm/config.d/config . worked for me (xps 9360 and Ubuntu 18.04)
    – oligofren
    Apr 16 '18 at 16:26
  • 1
    I ended up replacing the wireless card with an Intel one. That works great!! And only thirty bucks.
    – MagicLAMP
    Apr 17 '18 at 2:30
0

I was able to solve this on an XPS 13 9343 by switching to Legacy BIOS instead of UEFI running Ubuntu 19.04. None of the solutions I read about online have solved this, but switching off UEFI did the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.