1

When my desktop rebooted after upgrading Ubuntu Gnome 15.10 to 16.04, startup gets stuck in a state where it constantly switches between a terminal and graphics mode, as if it tries to start graphics but fails. It keeps doing that every 10 seconds or so.

My system is a recent PC desktop with a decent NVidia GeForce GTX 970.

So I suspect a problem with the graphics drivers, and I'm savvy enough to try and repair it from a console... IF the system would let me have a console.

When I CTRL-ALT-F1 for the TTY1 console, I'm lucky if I can squeeze in a couple of keystrokes before it switches back to graphics (which doesn't work). Then I need to hit CTRL-ALT-F1 again to try and get the next few keystrokes in. This is not workable.

So then I decided to restart in repair mode. Same problem: can't get a working console.

So then I decided to try and repair it using the live DVD. But when I boot it it gets stuck. I get passed the UEFI stuff. I tried both "Install ubuntu..." and "Try without installing...", but in both cases startup just get stuck after a couple of minutes DVD activity.

Inspired by https://help.ubuntu.com/community/BootFromCD and https://help.ubuntu.com/community/BootOptions, I tried with several combinations of boot parameters, such as vga=791, noapic, noacpi, ... But none seem to make any kind of difference.

I've been using Ubuntu since Hardy, and I've hit "system broken after upgrade" problems several times before, but in all cases I was able to fix them using a console and/or live DVD. Except this time...

So I'm basically dead in the water here.

1

It is very difficult to type in a constantly switching console, but not impossible. I found out that the constant switching was caused by gdm3, so I stopped stopped it:

sudo /etc/init.d/gdm3 stop

I could probably have done it by ssh-ing to my desktop as well, which would probably have spared me the difficulty of having to type in a constantly switching console.

Once I got my console back, I figured out that it was a combination of the kernel and the nvidia-304 driver that was causing the problem (the usual suspects). This got my system working again:

  1. Manually install kernel 4.5.2, as explained here: http://www.ubuntumaniac.com/2016/04/update-update-to-linux-kernel-452-on.html
  2. Purge nvidia-304 and install nvidia-361

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.