0

Ubuntu 16.04 is a nightmare! I have had to fix mysql php zoneminder ... my website doesn't work anymore and owncloud is giving me an error.

When I try to open owncloud I get the following:

Internal Server Error
The server encountered an internal error or misconfiguration and was
unable to complete your request.
Please contact the server administrator at xxxxx@xxxxx.xxx to inform
them of the time this error occurred, and the actions you performed just    
before this error.
More information about this error may be available in the server error log.

Moreover, when I check the error.log I see :

AH00027: No authentication done but request not allowed without
authentication for /owncloud. Authentication not configured?

I guess updating also updated my apache2 from apache2.2 to apache2.4.18 and I'm assuming that is why my website is completely hosed and so is owncloud. I have no idea what to do about this error .. weird thing is .. it works fine on my phone to view the list of files, I cant download anything, but I guess I can view the list because its an app not a "website" and the app is doing the auth like it should.

I finally got zoneminder to work so I know that MySQL and PHP are working. I tried to look it up and only found stuff like you need to have authz_core_module installed .. I believe I do... authz_core is enabled in my apache modules. I'm at a loss... any suggestions?

Edit: Still working on the issue ... I have changed the line in the owncloud.conf from Require valid-user to Require all granted and now I get this when I try to load the page:

<!DOCTYPE html>
<!--[if lte IE 8]><html class="ng-csp ie ie8 lte9 lte8" data-placeholder-focus="false" lang="en" ><![endif]-->
<!--[if IE 9]><html class="ng-csp ie ie9 lte9" data-placeholder-focus="false" lang="en" ><![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--><html class="ng-csp" data-placeholder-focus="false" lang="en" ><!--<![endif]-->
    <head data-requesttoken="">
        <meta charset="utf-8">
        <title>
        ownCloud        </title>
        <meta http-equiv="X-UA-Compatible" content="IE=edge">
        <meta name="referrer" content="never">
        <meta name="viewport" content="width=device-width, minimum-scale=1.0, maximum-scale=1.0">
        <meta name="apple-itunes-app" content="app-id=543672169">
        <meta name="theme-color" content="#1d2d44">
        <link rel="shortcut icon" href="Memcache \OC\Memcache\Redis not available for local cache Is the matching PHP module installed and enabled?

Maybe this will help .. guess the more information the better.

1

I had the same problem. Fixed it by replacing my config/config.php with the version from the owncloud package, and re-entered the mysql settings. I hope this solves your problem too

1
  • 1
    I wasn't able to find one that came with the package other than a sample which wasn't very helpful but I renamed my config.php then tried to enter the site... and it gave me a setup screen where I could enter the data. Once done it gave me an error because the user already existed. I deleted the user from the db and tried again and got another error but it had created a partial config.php .. I just looked around and took out of my original the items it still needed. It seems my problem was the lines containing //OC//Memcache. With those gone I got an update screen and now its working – John Orion Apr 27 '16 at 17:39
0

I found I had to reinstall owncloud after upgrading from ubuntu 15.10 to 16.04. I think it was the upgrade from php5 to php7 that broke everything. Owncloud supports php7, but maybe it requires reinstallation to use it. Just to note, I installed owncloud from the package available via opensuse. The steps I took were:

sudo apt-get remove owncloud

I then edited the source list file that the upgrader disabled and uncommented the source line (remove the # symbol in front)

sudo vim /etc/apt/sources.list.d/owncloud.list

Then I updated and reinstalled

sudo apt-get update
sudo apt-get install owncloud

When I went back to my owncloud url, it presented a typical owncloud upgrade screen that proceeded for around 1-2 minutes, then my login appeared. Hope this works for you.

2
  • Thanks... I actually did reinstall owncloud because when I first upgraded I tried the site and it wasn't working.. when I looked in the owncloud folder most of the files were gone. I did no that the upgrade would disable sources so I did put them back in... tried to change the one to 16.04 but it doesn't exist yet so i left it at the 15.10 and reinstalled it. Then I was getting those errors... Strange thing is .. I decided to try again using your steps but when I did remove owncloud it said it wasn't installed. I uses synaptic to visually see what owncloud items were installed and it wasn't. – John Orion Apr 25 '16 at 15:18
  • Unfortunately, this did not solve my problem. I installed it so I can uninstall it, then I reinstalled it but I still have the same errors. I think it's has to do with Apache more than owncloud. As I mentioned my website doesn't work anymore .. just shows a blank page and no errors that I can find anywhere to point me to where to start to fix it. I think it has to do with the auth thing because all my pages access MySQL and I'm assuming failing because it probably isn't even trying to access the sql server. – John Orion Apr 25 '16 at 15:21
0

I had different issues with my 16.04 upgrade but eventually got it working. Make sure there is an owncloud.conf in /etc/apache2/sites-enabled and /etc/apache2/conf-enabled. Also make sure your data directory is configured correctly in /var/www/owncloud/config/config.php and also make sure the www-data user/group owns and has read/write permissions. If you're still having issues lookup the manual install instructions and make sure all the needed php modules are installed and enabled (can't link because the owncloud website is blocked at my work for some reason). The manual instructions have all the modules as php5_modulename, so just use php_modulename instead to get the php 7 version.

Don't forget to check the apache error log at /var/log/apache2/error.log to see if it gives you any helpful errors.

2
  • Installed properly with proper permissions. Tried to look up the manual install but its not "user friendly" it says make sure all these modules are installed but doesn't explain how to check or anything. I'm assuming everything is installed because it used to work. Even after checking everything I still get the same error as above "No authentication done" I think its a PHP / Apache issue but again no idea how to set up PHP7 .. the INIs are different so I can't even try to make sure everything is set the same as it was in PHP5 and as I said before .. my whole website just displays a blank page – John Orion Apr 25 '16 at 17:13
  • just checked with phpinfo .. yes all the required items are installed. – John Orion Apr 25 '16 at 17:29
0

The solution should not be to replace your custom config.php owncloud configuration file, with the default one. By doing that, you have turned off additional settings you have made, like caching.

Problem here is that you have upgraded OS version and, also, PHP version, among other stuff. REDIS PHP extension is compiled for an earlier version of PHP and there's a mismatch between those two.

You can run in shell:

php -v

The above will return something like:

PHP Warning: PHP Startup: redis: Unable to initialize module REDIS compiled with module API=20050922 PHP compiled with module API=20090626

These options need to match in Unknown on line 0

You can temporary comment out REDIS server config in OwnCloud config/config.php to make it operational, but I suggest to fix this problem (same thing as replacing custom config.php with default config.php and entering new values).

Now, to the solution :) ... to fix this, you need to compile (upgrade) REDIS PHP extension. There is a GITHub project. Go to shell and:

Enter TMP dir, create directory named "redisphpext" and enter into it...

cd /tmp
mkdir redisphpext
cd redisphpext

Download GitHub project and extract it:

wget https://github.com/nicolasff/phpredis/archive/master.zip
unzip master.zip
cd phpredis-master

Compile :) :

phpize
./configure
make
make install

After that, remove comments from REDIS configuration in config/config.php (if you commented it out).

That should solve your problem and you should have your OwnCloud fully operational.

P.S: If you messed up with the "redis.ini", you should add one line in it:

echo "extension=redis.so" > /etc/php5/conf.d/redis.ini

or you can use vi, vim, nano... to manually enter line in redis.ini:

extension=redis.so

That's all.

0

I just worked through upgrading the server Owncloud is on from Ubuntu 14.04 to 16.04, I found this was what I had to do to restore everything;

  • Re-Add the Owncloud apt repository
  • do sudo apt-get update
  • do sudo apt-get install owncloud

Doing this installed the required dependencies and kicked Owncloud into maintenance mode. Owncloud recognized it's own installation and left the existing data alone and picked up the old config.

I then had to re-configure apache2 according to the Owncloud Docs. Once apache was reconfigured I could then do occ maintenance:mode --off in Owncloud's root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.