I discovered several issues with wifi connection after installing 16.04 LTS.

First, wifi doesn't reconnect normally after sleep or hibernation. Sometimes the network icon turns into a "up and down arrows"(I don't know what it is for) after waking up but is still connected. Sometimes network is simply lost and it doesn't display any network in the list so there's simply no way to use wifi at all.

I first tried restarting network manager by running sudo service network-manager restart. It worked but was not a permanent resolution.

Then according to another thread, I added SUSPEND_MODULES="iwlwifi" to /etc/pm/config.d/config.

After doing this, the reconnect issue seems to be fixed (can automatically reconnect and icon doesn't change any more). However, I find the wifi connection gets lost randomly (about every 30 minutes) even when the computer is running and the network icon remains the connected state when connection is lost.

Another issue after adding the code is, when I put my computer to sleep, the screen will turn off for a second but then turns back on for around 5 seconds(during which the system will cut off wifi connection). And then the computer will go to sleep after this unusual "two-phase" process.

Wireless cards info below

*-network               
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: b0:c0:90:5c:1c:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-21-generic firmware=N/A ip=192.168.0.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller (rev 01)

05/01/2016 Update
I don't know what happened but the issue gets worse now. Wifi connection gets lost about every 5 minutes and I have to reconnect or restart network-manager.

  • 1
    The up & down arrows are for wired connections - I see them if I use tethering to an android device, for example. There are lots of bug reports related to your card for example this one where it seems installing new drivers worked for some folks. Maybe you will find something... – Zanna May 1 '16 at 20:43
  • 2
    You should have used SUSPEND_MODULES="rtl8723be" instead of iwlwifi as you card doesn't use iwlwifi. Also try echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf and reboot – Jeremy31 May 1 '16 at 21:26
  • 1
    It may fix both the fwlps option disables power management and that can cause disconnects and other issues – Jeremy31 May 1 '16 at 21:38
  • 3
    I have seen many question on wifi issue and don't understand one thing that why there is so many issue related to network, especially wifi in 16.04 LTS. – d a i s y Aug 9 '16 at 9:38
  • 1
    @RyanNerd and once they have the Mac, run Ubuntu on it of course! The one good reason to get the Mac in the first place :-) – zwets Oct 30 '16 at 21:33
up vote 44 down vote accepted

Finally I was able to fix the issues after trying out numbers of different methods.

  1. Get details of your PCI wireless card by running sudo lshw -class network
  2. Get your card model info according to the product line.
    For instance, as you can see in the question description it says
    product: RTL8723BE PCIe Wireless Network Adapter so the model of my card is RTL8723BE

    Or product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller so the model of my card is RTL8101/2/6E

  3. Give the permission sudo chmod 755 /etc/pm/config.d/

  4. Open or create config and add SUSPEND_MODULES="rtl8723be"(replace rtl8723be with your own model number)
    Then run
    echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    (note that when replacing rtl8723be with my card which is RTL8101/2/6E i should only type .../modprobe.d/RTL8101.conf; and /2/6E shouldn't be written)

Finaly restart your system.

Now your system should be able to reconnect automatically after sleep, and wifi connection never got lost once for me after doing this.

"The up/down arrows is likely a network manager bug that results in network manager thinking the wifi device is actually ethernet.", according to Jeremy31.see bug info here You should be able to fix it by installing NetworkManager-1.2.0.

Thanks to Jeremy31 for providing the solutions.

  • 4
    This works as a fix to the wake from suspend issue. It is the third solution that works for my laptop with an Intel 7260 wifi card. But even after installing NetworkManager-1.2.0, I still get the arrows (mine are horizontal, not vertical) and a completely disconnected wifi card when I try to switch networks. – Rsync May 9 '16 at 2:45
  • 4
    I've installed ubuntu 16.04 few hours ago and got the same issue (wrong icon + wifi lost randomly). Seemed solved with sudo apt-get update && sudo apt-get dist-upgrade. After reboot, everything was all right: connections more stable and no wrong icon. – gwarah Jun 20 '16 at 17:50
  • 1
    There is no "product: " attribute returned for my wifi dongle. Only "configuration: ... driver=r8712u ..." – James Bowery Aug 19 '16 at 12:47
  • 2
    Be careful with this solution. It completely borked my networking on LM18. I had to remember what commands I did so I could remove the configuration files and reboot. Print this page in case you need to reference the process. I'm not saying it is bad, it obviously worked for some people. But thought a warning is in order here. – RyanNerd Oct 26 '16 at 5:50
  • 1
    @KillABug - The above problem and/or solution may be Realtek specific; with the Centrino device I have no problems after sleep but lose connection randomly maybe especially during downloading. Ignoring IPv6 didn't fix it. – cipricus Mar 6 at 10:33

I have the exact same problem. After waking from sleep, wifi still works but networks not showing. I solve the problem by restarting the network manager.

sudo service network-manager restart

Still very annoying. I hope they fix this issue soon.

  • 10
    This is only a temp solution. Do you think it's a bug with 16.04 LTS? – Lixu Apr 28 '16 at 21:07
  • 3
    that work for me. it is probably a bug. – avi software May 2 '16 at 7:51
  • 2
    also works to use nmcli con up wifi-sid, if you want a quick bodge. – Rick-777 Jun 20 '16 at 19:01
  • 4
    This did not work for me. I'm running Xubuntu 16.04 LTS and was connected to a Windows shared drive when my computer went to sleep. Running sudo service network-manager restart just froze my system up even worse. I then did a Log off and back on--even worse still, & now my desktop icons disappeared. Then I did a full restart and now my desktop icons are still disappeared. No idea why, but I'll be disabling sleep for sure. This is a bad deal. These types of problems where simple stuff should work really make me miss Windows, and I don't like that feeling. I hope Ubuntu/Xubuntu gets better. – Gabriel Staples Sep 3 '16 at 3:57
  • 2
    Did you find a solution yet? – Emad Arshad Alam Nov 10 '16 at 3:54

This is a bug for sure. Bug has been filed at https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1574347

  • That bug's been closed, do you know of another one that I can mark myself as affected by? :) – Ads20000 Jul 23 '17 at 15:46
  • Maybe that bug was closed, but mine does still drop occasionally; and I never use suspend. askubuntu.com/questions/938321/… – SDsolar Aug 1 '17 at 0:44

Additional info: I have the same exact problem as OP describes, but only the problem where the nm-applet icon changes to arrows and does not display wifi info. The wifi still works when this happens.

$ killall nm-applet && nm-applet & 

Does the trick for getting the icon to display again, so it's just a workaround for now in case someone wants to put it into a script.

Can confirm this problem on two separate computers running xubuntu-desktop package.

Also, both computers I have run recent intel wifi cards. (something along the lines of AC-7260)

  • have you found out any solution – Lixu Apr 26 '16 at 16:22
  • Thanks, i have the same problem, but this only happens to me when i lose connection with the wi-fi router, sometimes it happens that my router gets bugged and lost connection. – Aleksandar Đorđević Sep 20 '16 at 20:12
  • 1
    I have met exactly the same problem as described here on the recently released manjaro-i3-20161201. And successfly have it fixed using this trick. Thank you! – navigaid Dec 8 '16 at 14:56
  • Another thing I found useful is, if you will, remove /etc/xdg/autostart/nm-applet.desktop to keep it from starting on boot and alternatively use the nmtui utility instead to connect to a wifi in terminal. I tried the method and the connection automatically reconnects when my laptop recovers from sleep, even after nmtui quit running. – navigaid Dec 8 '16 at 15:40

I was having the same problem. I fixed the suspend wake issue by creating this script at /etc/systemd/system/wifi-resume.service (the one the OP posted only worked for the active session; on reboot it had to be called again):

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Then just issue this command in terminal to activate it: sudo systemctl enable wifi-resume.service. This solution is from another askubuntu question answer, and works both after suspend and after reboot.

However, even after that was fixed, I get the same behavior that used to happen on wake from suspend when I try to switch wifi networks: the wifi is essentially dead, with the two arrows, and the applet says "device not ready." I can restart the wifi by issuing sudo service network-manager restart, but I can't switch networks.

Is anyone else experiencing this and/or have a solution???

  • 1
    Since you still got the issue, what good does the script do anyway? – Lixu Apr 29 '16 at 2:33
  • The script FIXES the OP's first problem: no wifi on wake from suspend. However, it does NOT fix the second problem (for me): can't switch wifi networks without losing wifi access. If I wasn't clear, the second problem exists independently of the first. The script does not create the second problem, it merely corrects the first. – Rsync Apr 29 '16 at 5:20
  • I dont think this script does anything for my situation. It turned out wifi connection gets lost more frequently after using it. – Lixu May 1 '16 at 15:24
  • Try one of the other scripts around (e.g., askubuntu.com/questions/761180/…). Both worked for the wake suspend issue. However, the inability to switch networks issue caused me to roll back to 15.10. Also, on a fresh install of 16.04, I encountered a third issue: network manager created a new wifi connection each time I connected to a network (e.g., WIFI_1; WIFI_2; WIFI_3). As a result, I needed to input the password each time. – Rsync May 2 '16 at 18:27
  • I don't use resume but this looks promising. Thank you for posting this. Here is my question and a good answer on the issue: askubuntu.com/questions/938321/… – SDsolar Aug 1 '17 at 0:46

I'm using LinxuMint 18 Mate (ubuntu16.04) and got into the same issue.

All the rest above didn't work for me on my thinkpad T440S.

The only workaround that seems to work until now is upgrading kernel to 4.6.3

  • Go to this website.

  • Get the following files:

    linux-headers-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    linux-headers-4.6.3-040603_4.6.3-040603.201606241434_all.deb
    linux-image-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    
  • From a terminal, go to the folder containing the above files and run:

    sudo dpkg -i *.deb
    sudo reboot
    

If you are using Virtualbox, run this sudo /sbin/vboxconfig

In case you want to remove them, run:

sudo dpkg --purge linux-headers-4.6.3-040603 linux-headers-4.6.3-040603-generic 

After some more tests, situation is almost the same, I got wifi, but my nm-applet is unable to see all WIFI around me. So not sure if this a good workaround :-)

  • Using LM18 as well. All other solutions killed my networking. This solution seems to be working. I am using Cinnamon and the kernel upgrade borked my Nvidia driver -- Not the kernel's fault. I'm certain the devs at Nvidia are on acid b/c they can't follow their own specs every time I do a major kernel upgrade I spend an hour or more fighting the nvidia driver stupidity. – RyanNerd Oct 26 '16 at 5:45
  • 1
    I upvoted this and leaving it upvoted because upgrading to the latest kernel works for LM18 where I looked other places did not do nice things to my system. Unfortunately upgrading to kernel 4.6.3 did not solve my wifi going stupid at random times. Only happens at home. I have the exact same router at home that I have at work. Not sure what is going on here. My laptop has an Intel Wireless 7260 which apparently is a badly drainbramaged wireless adapter version that has several issues in Linux and Windows. So I guess I'm stuck until the driver is updated for this piece of s__t hardware. – RyanNerd Oct 26 '16 at 21:11

There is no solution at all right now but I found a script that helped me to keep wlan up:

#!/bin/bash

# Ping you most used DNS Server and reconnect on fail


while true; do
  if ! ping -c 1 -w 1 8.8.8.8 > /dev/null; then

    # with "sudo iwconfig" you can examine your name of 'wlan0'
    nmcli d connect wlan0

  fi
  sleep 2;
done

to Autostart this script simply open gnome-session-properties and add it to the list.

The full script (without reconnect) can be found on this web page.

Set the WIFI country code for the Kernels current regulatory domain if it isn't set

iw reg get

To set it

sudo nano /etc/default/crda
REGDOMAIN=<ISOCODE>

Reboot.

  • How or why would this help? – A-B-B Mar 17 at 23:28
  • This solution helped me to some extent. Before it sometimes took minutes to establish WiFI connection (I had to restart network-manager few times, sometimes I had to restart computer) but after explicitly setting REGDOMAIN now it works better. But after waking computer from sleep it still sometimes fails to connect and I have to manually restart network-manager. Annoying. – kovinet Mar 31 at 9:13

just to add on for the accepted answer (with four steps)

for some reason only one step was enough for me, even if I don't know what it means:

echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

protected by Community Aug 20 '16 at 17:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.