This option, which was present in the "Mouse and Touchpad" settings panel in previous versions, is for some reason absent in 16.04 LTS. Does anyone know why this is, and/or how to fix it? Thanks.

  • 1
    All the suggestion here don't work for Ubuntu 16.10. As a matter of fact, the solution of @DevNull will disable your trackpad completely. I'm still looking for a solution, but wanted to comment so people are not getting their trackpad disabled. – Nitai Nov 29 '16 at 1:23
  • @Nitai's comments goes the same for me as of Ubuntu 17.10 – LeoRochael Feb 7 '18 at 18:03
  • ArchLinux user here: I installed synaptics and xorg-input and either of these brought the setting back. – phil294 Mar 24 '19 at 10:08

I found a similar question AskUbuntu which provided a link to the details needed to solve this issue.

In short, edit your quirks file:

sudo vim /usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf

And add the following to the end of the file:

# Disable generic Synaptics device, as we're using
# "DLL0704:01 06CB:76AE Touchpad"
# Having multiple touchpad devices running confuses syndaemon
Section "InputClass"
        Identifier "SynPS/2 Synaptics TouchPad"
        MatchProduct "SynPS/2 Synaptics TouchPad"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/event*"
        Option "Ignore" "on"

Now restart Xorg:

sudo systemctl restart lightdm

Now, just start syndaemon as usual:

killall syndaemon
syndaemon -i 0.50 -m 0.10 -d -K

Note: For some reason, two-finger scrolling didn't work until I fully rebooted my laptop, but it eventually started working.


I eventually installed touchpad indicator like another answer suggests, when I had to switch to a different Dell laptop, and this fix no longer worked.


This works fine for me (ubuntu 16.04):

sudo add-apt-repository ppa:atareao/atareao  
sudo apt-get update  
sudo apt-get install touchpad-indicator

Launch touchpad-indicator, and go to the Actions menu. Select the Disable the touchpad on typing option.


  • 1
    I've used this, but have found it to be quite unreliable. One major annoyance is the fact that is interprets keyboard shortcuts (such as CTRL+S) as 'typing', meaning every time I save I have to wait half a second before I can use the mouse. EDIT: my bad, you need to killall syndaemon first. – Niek Mar 30 '17 at 9:48
  • worked for me dell latitude 5580 – Ramesh-X Feb 15 '18 at 4:03

Adding to DevNull's solution, I added this command:

syndaemon -i 0.50 -m 0.10 -d -K

to my startup application's command. In this way, it still works even after rebooting.


When searching the internet for an answer to this problem, I found a page that suggested using syndaemon to accomplish this (found here: http://www.webupd8.org/2009/11/ubuntu-automatically-disable-touchpad.html). I used the command "syndaemon -i 2 -d -K" in terminal for my needs. This command disables the touchpad while typing for two seconds (-i 2), except when modifier keys such as Alt or Shift are used (-K).

Hope that helps!

  • what version of ubuntu are you on? – Alexander Mills Dec 2 '16 at 21:43
  • I don't seem to be able to change the interval. syndaemon -i 10 -d -K still disables for 2 seconds, not 10. – Niek Mar 30 '17 at 9:51

The touchpad settings are gone probably because libinput has been installed. It does not have GUI settings.

In Ubuntu 16.10 it is installed by default.

You can either remove xserver-xorg-input-libinput or xserver-xorg-input-libinput-hwe-16.04 to get GUI back, or use a config file for this kind of settings.


In gnome exists an extension that works perfect: https://extensions.gnome.org/extension/131/touchpad-indicator/

  • Ubuntu 16.04 LTS uses Unity, and not GNOME Shell, by default. This only works if you've installed gnome-shell or ubuntu-gnome-desktop or are using the GNOME flavor of Ubuntu. – Lucas Sep 21 '17 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.