I did a fresh install of Ubuntu 16.04 and found that menus for many applications do not show on the menu bar, as it is configured in 'Settings > Appearance'. For example: menus for Filezilla, Geary, Libreoffice Writer and Software center do not show. I have not tested every app, but I can tell you that browsers (Chrome, Firefox) do have their menus on the menu bar. In addition, if I change the configuration to show menus "in the window's title bar", they don't show either.

Any clues?

Best regards.

  • 5
    I too am experiencing this issue, the install was working perfectly. Today they just suddenly disappeared... – rlam12 Apr 25 '16 at 19:53
  • I'm not sure why, but now I seem to have all my menus back. I recently install MEGA Sync, and had to restart nautilus. So maybe that did the trick, though i'm not really sure if nautilus has anything to do with it. – Esteban Knöbl Apr 27 '16 at 1:00
  • 1
    Seriously, 16.04 should have never been released with this bug. That's making the release almost unusable for normal users. – sstn May 21 '16 at 9:53
up vote 37 down vote accepted

This is a reported bug that is being addressed by the developers.

Bug report:
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1532226

Missing on Startup

Running this command in a terminal window will bring back the menus for the current session:

$ initctl restart unity-panel-service

To save time and having to:

  • Check first to see if the issue is resolved
  • Open a terminal Window
  • Run the command

I wrote a short script and added it to my startup apps. The script will do all the above. I'll have three minutes to notice if the problem is fixed of which I can disable the startup script once the bug is fixed.

There's a sound notice to nudge me to check if it has been fixed... then finally the command is automatically run.

The menus will be fixed 4 minutes after each reboot.

Script named resetmenus.sh:

#!/bin/bash
sleep 180
espeak "Resetting unity-panel-service"
sleep 60
initctl restart unity-panel-service

The script can be added to startup by typing startup applications in the Unity Launch Search Button.

Disappearing during logged in session

The script above resolves the menu problem that is always missing upon boot. The menu subsequently disappears between boots. When this happens I find the AltCntlT to bring up a terminal and typing unity as mentioned in the previous answer is ideal for that instance.

  • 5
    initctl restart unity-panel-service also works for menus disappearing during current session. Also it doesn't seem to crash open applications,. This should be the accepted answer. – xShirase May 15 '16 at 13:36
  • This answer is the one that really solved my problem too. – Leonardo Castro May 25 '16 at 12:21
  • 2
    for ubuntu 16.04 using systemd instead of upstart, you should issue command like this restart unity-panel-service. If using initctl restart you may get a upstart error message since 16.04 is not using upstart. – Xianlin Aug 3 '16 at 3:03
  • Thanks ! it works. I was going to install gnome classic menue. But I love Unity and Ubuntu though there are some bugs. Seems Ubuntu 12.04 was the best one I have ever used. – Razib Aug 9 '16 at 1:59
  • 1
    // , This no longer works. Both restart unity-panel-service and initctl restart unity-panel-service do not work on Ubuntu 16.04: restart: Name "com.ubuntu.Upstart" does not exist. – Nathan Basanese Sep 11 '16 at 19:24

Apparently it is a confirmed bug on the release... A fix is being investigated. You can see the bug report here

The temporary solution is to open a terminal with ALT + CONTROL + T and typing unity. This will cause the UI to reset and fix the problem. You'll need to so this every time you boot and it happens.

It is still unknown why it happens, but it affects about 30% of boots.

  • I'll edit the answer afterwards once I find again the bug report. Got lost on my tab history heh... – rlam12 Apr 27 '16 at 1:07
  • Thanks for the clarification! I hope that it gets fixed soon. – Minas Mina Apr 27 '16 at 20:48
  • 6
    This brought the menu back but crashed half of the programs I was running (such as Chrome, Atom IDE, Filezilla). This is a pretty serious bug, I'm looking forward to a real solution. – revnoah May 1 '16 at 3:53
  • 5
    Warning: This will kill all the running user-applications !! See the other answer for a better solution. – Anmol Singh Jaggi May 16 '16 at 18:30
  • 1
    this works to me. on ubuntu 16.04. – cul8er Aug 15 '16 at 21:39

I had the same problem, and I did what you explained:

sudo apt-get remove libreoffice-gtk

Thank you very much for the help, of course. I have uninstalled 2 files (libreoffice-gtk and libreoffice-gnome) and then the menu appeared (old version).

But then I tried installing again only libreoffice-gtk:

sudo apt-get install libreoffice-gtk

...and opening the libreoffice, the menu appears correctly (new version).

It may be coincidence, but it worked.

  • // , Did the problem ever come up again? – Nathan Basanese Sep 11 '16 at 19:18

I had a same problem with applications like LibreOffice 5 and terminal and gedit. Menu bar was missing from these applications. It occurred after upgrading Ubuntu to 16.04 LTS from 14.04 LTS... I used following two commands and it worked for me...

dconf reset -f /org/compiz/

setsid unity

Use above two commands and I hope it will work for you also...

It happened to me in an upgrade (15.10 -> 16.04), since I couldn't fix it I created a new user and everything looks fine there.

edit!

With the hurry no longer there, I went back to try recovering that user profile. Eventually I managed to get a terminal for that user (use F2, F3... until you get a -full screen- terminal), then I was able to login as the wounded user and run this commands:

dpkg --configure -a

Optionally, you can use this commands to clean and reconfigure the installed packages:

apt install -f
dpkg-reconfigure --force
  • Added follow up, it may be of help to fix the broken user-profile. – Fernando Murrieta Sep 27 '16 at 21:02

Run

sudo apt-get install indicator-appmenu

If this actually installs something, then you likely found the problem. I'm not sure what is the easiest way to actually activate the appmenu, but rebooting did the job for me.

  • (I had previously uninstalled indicator-appmenu because it disabled TeXmaker's keyboard shortcuts, but that bug seems to be resolved.) – dremodaris Jul 26 at 10:40

protected by Community Apr 27 '16 at 6:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.