6

In Ubuntu 16.04: when I run sudo nautilus from the terminal, a new window pops up but no arrow indicating an opened window appears besides the nautilus icon at the unity panel. When I minimize the root window and then click again on the icon, instead of opening the root window, a new non-root window pops up and suddenly two arrows appear near the nautilus icon. (Not even scrolling on top of the icon works to show the minimized window.) When I close the non-root window, only then the arrow indicating the root window stays on the panel and everything works like it should.

I also tried removing the nautilus icon from the panel and run sudo nautilus from the terminal. In that case a new icon appears with the arrow and everything behaves normal.

Is there a way to fix this? It is annoying.

  • 4
    Try gksu or gksudo nautilus because sudo wont really create a correct execution environment for GTK (programs w/ gui) programs. – ForceMagic Apr 24 '16 at 21:50
  • No, not even with gksu. And in addition to that, after running gksu nautilus my wallpaper reset to the default 16.04-one. Only after clicking the nautilus icon again, the arrows appeared and my custom wallpaper is back. – Václav Pavlík Apr 24 '16 at 21:54
  • Now that is very interesting.... I have literally no idea whats going on there. Have you tried apt-get update && apt-get upgrade – ForceMagic Apr 24 '16 at 21:57
  • Comment to the GUI: When I run e.g. sudo kate it does show the arrow besides an existing icon... And I have never used gksu on 14.04 and still after running sudo nautilus there the arrow showed every time... – Václav Pavlík Apr 24 '16 at 21:59
  • I installed the newest automatic updates through the update manager few minutes before posting this question and now I did it again through terminal. The issue remains. Also I have just spotted that after closing the nautilus root window, the terminal does not seem to end the process untill I press Ctrl-C. (While running sudo kate and closing the window, the terminal resets itself normally.) – Václav Pavlík Apr 24 '16 at 22:08
6

First killall nautilus processes:

sudo killall nautilus

Then re-install the data package:

sudo apt-get install --reinstall nautilus-data

  • Please, first read, then post. In the first answer I added a comment (May 24), that sudo apt-get install --reinstall nautilus-data does not solve it. Now you are proposing it as an answer. And it is also a duplicate of an existing solution that has been already linked to the provious answer. – Václav Pavlík Sep 7 '16 at 20:11
  • @VáclavPavlík, I'm proposing you killall nautilus processes before running the re-install. It works for me, so it's an answer. – wulfgarpro Sep 8 '16 at 5:37
  • Please read again and carefully the third line in the answer from May 22, especially the first three words. Your post is no different from what has already been suggested. – Václav Pavlík Sep 9 '16 at 10:06
  • @VáclavPavlík, The solution works for me; the answer you're referring to doesn't have an explicit command for the Ubuntu OS and therefore isn't very helpful for people who don't understand what kill is. My answer is more descriptive and might help someone down the line whose problem might be solved, just as it was for me. – wulfgarpro Sep 10 '16 at 22:55
  • it works for me with kill all before reinstall – bogdan.rusu Nov 12 '16 at 14:27
1

I had this problem with Ubuntu 16.04, kernel 4.6. I followed these instructions and it's working now. Nautilus won't launch [16.04]

Kill nautilus process, reinstall data:

sudo apt-get install --reinstall nautilus-data

and try again.

  • Unfortunately sudo apt-get install --reinstall nautilus-data does not solve it. – Václav Pavlík May 24 '16 at 14:58
1

For ownership of files reasons, using sudo for nautilus is not preferable. Having researched various responses, in particular this and this post, neither are the gksu or gksudo commands.

Instead, it's suggested to use pkexec. You can install this and add it to nautilus via :

sudo apt-get install nautilus-admin

Running pkexec from a terminal will still not let you see the window on the unity bar.

However, by installing pkexec through nautilus-admin there is a right click option in user version of nautilus to open as an administrator. I found this window will retain an arrow in the unity bar along with the original window it was opened from (ie, close the original window just to have an administrator nautilus window open)!

  • I believe that there must be a better way to make nautilus communicate with the unity bar. I was looking into a response given on a similar problem which started looking at adding root to a group called dbus. . However, using Ubuntu 16.04 I cannot find such a group listed in /etc/group as suggested. – Mr G Jun 28 '17 at 1:35
  • This seemed relevant seeming errors when running sudo nautilus often seem to have references to Dbus. ie: "Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name..." Presumably Dbus allows communication to the unity bar of the app's status? – Mr G Jun 28 '17 at 1:44
  • 1
    Rather than posting two comments under your own answer, I believe you can edit your answer by clicking the edit button. – WinEunuuchs2Unix Jun 28 '17 at 1:50
  • Thanks @WinEunuuchs2Unix! I intended to add as comments, to keep the solution clear. I wanted to generate discussion of a potential better solution. – Mr G Jun 28 '17 at 1:51
0

There might be possibility of another File Manager is running in background. I had the same problem previously, Nemo was running in background. After killing Nemo process Nautilus started to work. (As I never use Nemo, I removed that program and now everything works great).

note: As I don't have enough reputation to add comment, I have given answer here. Thanks

-1

Method: Just open the terminal and type nautilus.

The disk icons will show up again and they will not disappear when you minimize them.

Had the same problem since I removed the disk icon (not nautilus icon) from the unity bar.

apt-get remove and apt-get install commands won't work.

  • Thanks but nautilus command works fine for me, sudo nautilus is what causes the problem. – Václav Pavlík Mar 16 '17 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.