4

Using these instructions, I could get gedit 3.10.4 to run on ubuntu 16.04.

Now, I need to install the version of gedit-plugins that corresponds to gedit 3.10.4. The sources are here but I have not been able to get them to work.

More precisely, I did:

dpkg: error processing package gedit-plugins (--install):
 dependency problems - leaving unconfigured
Processing triggers for libglib2.0-0:amd64 (2.48.0-1ubuntu4) ...
Errors were encountered while processing:
 gedit-plugins
cd Downloads/
cd gedit-plugins-3.10.1/
./autogen.sh

But I get:

Configuration:

    Source code location:   .
    Compiler:               gcc
    Prefix:         /usr/local
    Python Plugins Support: yes
    Plugins:                bookmarks bracketcompletion charmap codecomment colorpicker colorschemer commander dashboard drawspaces joinlines multiedit smartspaces textsize wordcompletion 

    Disabled plugins:       synctex (dbus-python not found), terminal (vte not found), git (libgit2-glib not found)

Note: you have to install these plugins into the same prefix as your gedit
installation (probably /usr if you're using your distro packages, /usr/local
if you have compiled it on your own).

So here is my question: how can I have gedit-plugins up and running? In particular, I need the terminal plugin to work.


P.S. I have already installed libvte-dev

Edit (wintermute's answer below)

yes, I have tried. Here is what I got:

Preparing to unpack gedit-plugins_3.10.1-1ubuntu2_amd64.deb ...
Unpacking gedit-plugins (3.10.1-1ubuntu2) over (3.10.1-1ubuntu3) ...
dpkg: dependency problems prevent configuration of gedit-plugins:
 gedit-plugins depends on python3.4; however:
  Package python3.4 is not installed.
 gedit-plugins depends on python3 (<< 3.5); however:
  Version of python3 on system is 3.5.1-3.
 gedit-plugins depends on gir1.2-gucharmap-2.90; however:
  Package gir1.2-gucharmap-2.90 is not installed.
 gedit-plugins depends on gir1.2-vte-2.90; however:
  Package gir1.2-vte-2.90 is not installed.
 gedit-plugins depends on gir1.2-zeitgeist-2.0; however:
  Package gir1.2-zeitgeist-2.0 is not installed.
  • Try apt-get install gedit-plugins:version, where version is the correct version number for gedit. – ForceMagic Apr 24 '16 at 22:08
  • As far I understand you want to `./configure --prefix/usr --with-plugins=terminal && make && make install – Videonauth Apr 24 '16 at 22:09
  • I didn't mean gedit's version instead look up what versions of gedit and gedit-plugins work together and write that version there. – ForceMagic Apr 24 '16 at 22:14
  • @Force: thanks! the correct version seems to be 3.10.1-1ubuntu2 but apt-get install gedit-plugins:3.10.1-1ubuntu2 gives E: Unable to locate package gedit-plugins:3.10.1-1ubuntu2 E: Couldn't find any package by glob 'gedit-plugins:3.10.1-1ubuntu2' E: Couldn't find any package by regex 'gedit-plugins:3.10.1-1ubuntu2' – user2413 Apr 24 '16 at 22:18
  • oops, my bad equal sign there the colon is for arch (amd64,i386, etc) – ForceMagic Apr 24 '16 at 22:20
2
+50

I had to find out that the build process isn't so easy to solve. However I found another approach for you to get the old version of gedit and gedit-r-plugin up and running.

First removing the traces of your gedit compiling and installing tries (change the paths respectively to fit your situation).

cd ~/your build dir of gedit-plugins/
sudo make uninstall
cd ~/your build dir of gedit/
sudo make uninstall

The next command uninstalls the eventually existing 3.18.3 version of gedit, gedit-dev, gedit-plugins and gedit-common.

sudo apt-get remove gedit gedit-dev gedit-plugins gedit-common

Best to do the following steps in a clean seperate directory.

Now downloading the proper dependencies package for gedit-common 3.10.4 and installing it.

wget http://mirrors.kernel.org/ubuntu/pool/main/g/gedit/gedit-common_3.10.4-0ubuntu13_all.deb
sudo dpkg -i gedit-common_3.10.4-0ubuntu13_all.deb 

Then downloading the proper gedit 3.10.4 package and installing it

wget http://mirrors.kernel.org/ubuntu/pool/main/g/gedit/gedit_3.10.4-0ubuntu13_amd64.deb
sudo dpkg -i gedit_3.10.4-0ubuntu13_amd64.deb 

And downloading the proper gedit-dev 3.10.4 package and installing it.

wget http://mirrors.kernel.org/ubuntu/pool/main/g/gedit/gedit-dev_3.10.4-0ubuntu13_amd64.deb
sudo dpkg -i gedit-dev_3.10.4-0ubuntu13_amd64.deb 

Finaly downloading the proper gedit-plugins 3.10.1 package

wget http://mirrors.kernel.org/ubuntu/pool/universe/g/gedit-plugins/gedit-plugins_3.10.1-1ubuntu3_amd64.deb

We need to unpack this downloaded .deb file because we need to do two changes (sudo keps the packages owner intact).

sudo dpkg-deb -R gedit-plugins_3.10.1-1ubuntu3_amd64.deb tmp

First we are editing tmp/DEBIAN/control and change python3 (<< 3.5), python3 (>= 3.4~), python3.4 to python3 (>= 3.5~), python3.5.

sudo nano tmp/DEBIAN/control

Then we edit tmp/DEBIAN/postinstand change py3compile -p gedit-plugins /usr/lib/x86_64-linux-gnu/gedit/plugins -V 3.4 to py3compile -p gedit-plugins /usr/lib/x86_64-linux-gnu/gedit/plugins -V 3.5.

sudo nano tmp/DEBIAN/postinst

Now we can pack a new .deb file.

sudo dpkg-deb -b tmp gedit-plugins_3.10.1-1ubuntu4_amd64.deb

And changing ownership of the new .deb file (replace username with your username)

sudo chown username:username gedit-plugins_3.10.1-1ubuntu4_amd64.deb

Now finally installing it.

sudo dpkg -i gedit-plugins_3.10.1-1ubuntu4_amd64.deb

And now we download the proper gedit-r-plugin 0.8.0.2 package and install it.

wget http://mirrors.kernel.org/ubuntu/pool/universe/g/gedit-r-plugin/gedit-r-plugin_0.8.0.2-Gtk3-Python3-1ubuntu1_all.deb
sudo dpkg -i gedit-r-plugin_0.8.0.2-Gtk3-Python3-1ubuntu1_all.deb 

Only thing now left is protecting this all from upgrading.

sudo apt-mark hold gedit-common gedit gedit-dev gedit-plugins gedit-r-plugin
  • Do you have all sources enabled ? Ubuntu source, proposed, backport, cannonical etc ? – Videonauth Apr 30 '16 at 8:15
  • 1
    let me post my soures.list file. added it to my answer @user2413 – Videonauth Apr 30 '16 at 8:21
  • Btw why youre trying to compile that old version of gedit ? – Videonauth Apr 30 '16 at 13:30
  • 1
    Finaly found the culprit which prevented the terminal from being build, you might want to have a look again at my answer. @user2413 – Videonauth Apr 30 '16 at 15:31
  • Let us continue this discussion in chat. – Videonauth May 1 '16 at 6:59
0

Have you tried downloading the right version of the package compiled for an older release and installing it manually?

http://www.ubuntuupdates.org/package/core/trusty/universe/base/gedit-plugins for 3.10.1-1ubuntu2 from 14.04

http://www.ubuntuupdates.org/package/core/vivid/universe/base/gedit-plugins for 3.10.1-1ubuntu3 from 14.10

You can either use the graphic installer or install them from terminal with

$ dpkg -i ~/Downloads/package.deb
  • 1
    The answer to your question was too long to fit in a comment: I added it as an edit in the main text~ – user2413 Apr 29 '16 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.