I have lost the to me essential hibernate functionality after upgrading ubuntu. This is normal, but unfortunately I could not reenable it this time.

I tried these three previous solutions:

but no hibernation option appears.

Some additional info:

  • sudo pm-hibernate outputs nothing and appears to do nothing.

  • sudo s2disk outputs:

    s2disk: Could not open the snapshot device. Reason: Operation not permitted

I guess this is my key clue, but I didn't find any obvious explanations/solutions when googling that - I'm afraid I'm ignorant of the meaning.

There is no change to dmesg output and /var/log/pm-suspend.log does not exist after running pm-hibernate.

The machine is capable of hibernating under ubuntu 15.04 and earlier - the above options worked previously.

(I am aware this is a potential duplicate of this question, but wanted to add more detail.)

  • I have the same problem, only I can hibernate /suspend but my Lenovo z51-70 won't wake up from it. I even added the options that you provided. – Mookey Apr 24 '16 at 19:47
  • Take a look here. I just tested on both Ubuntu and Xubuntu 16.04, and it work on both. On Ubuntu I have to reboot for it to show in the menu. I will go ahead and close this as duplicate, but let me know if it fixes your problem or not, so I can reopen it. – Mitch Apr 25 '16 at 6:43
  • Take a look at a workaround I used – Enkouyami Apr 27 '16 at 3:22
  • @Enkouyami Thank you. What precisely do you mean by "and add your swap partition inside." - like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash /dev/sda3" – nsandersen Apr 29 '16 at 21:31
  • 2
    That is extremely odd. Can you please add this crucial information to your question? Does is change anything if you reinstall pm-utils (sudo apt-get install --reinstall pm-utils)? What's in /etc/pm/config.d/ and /etc/pm/sleep.d/? – David Foerster Apr 29 '16 at 23:37

You need to disable Secure Boot if you are using UEFI.

With Secure Boot enabled hibernation is disabled for security reasons.

  • 1
    Since Ubuntu won't tell you this, judging from OP, how would one quickly check whether Secure Boot is enabled? – matt Jun 17 at 12:16

In terminal, try sudo systemctl hibernate. If the system is able to do so, i.e. has enough swap space, it should work. Use of this command requires a password, which is not necessarily a bad thing, because it makes one pause to consider that the current system state is being recorded to a possibly-unencrypted HDD.

To make a Hibernate keyboard shortcut:

  • Press System and type key.
  • Select Keyboard settings.
  • on the Shortcuts tab, add to Custom Shortcuts the command systemctl hibernate and set a key combination. Note that sudo is not used here, though a password is requested when using the shortcut.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.