3

I have a Linux Ubuntu Mate 16.04 on an Intel NUC i5 NUC5i5RYK.

I had problems with headphones jack, just after 1 month was been purchased, and sent it to warranty, Intel changed it for a new one.

Now, I can' connect my Apple Keyboard via bluetooth: Ubuntu doesn't ask for pairing ping.

I can connect my Apple Magic Mouse, but not my Apple Keyboard.

I have researched hcitool and bluetoothctl without success

Before sending it to warranty, I connected the Apple keyboard, now I can't because I can't type the pairing ping

What can I do? remove the bluetooth manager and reinstall it?

Thanks a lot, I have been investigating it for a week, my last option is to buy another keyboard.

I'm not going to use Magic mouse with ubuntu, it disconnects periodically...each 10 minutes (+-) , but the keyboard worked successfully

3 Answers 3

2

Still without a solution I can't get it wroking.

These are the last actions I did:

  1. I changed the name of keyabord connected on a Mac
  2. Remove the file /etc/bluetooth/hcid.conf which contains information about the old name keyboard, something like: auth enable and encrypt enable
  3. Assigned (Or I think so) permisions to my user to bluetooth services: sudo usermod -G bluetooth -a albert

I don't know which one of these actions is the winner, but I hope can help someone, to avoid stay so long for fixing it

23/05/2016

After that, I had problems when connecting at startup. I have lost connection to keyboard, and so now, the problem persists

21/05/2016

Solved:

folowing this instruccions, I did:

# bluetoothctl -a 

[bluetooth]# pair 10:9A:DD:9C:3D:DA
Attempting to pair with 10:9A:DD:9C:3D:DA
[CHG] Device 10:9A:DD:9C:3D:DA Connected: yes
[agent] PIN code: 882876

[bluetooth]# trust 10:9A:DD:9C:3D:DA
Changing 10:9A:DD:9C:3D:DA trust succeeded

connect <address>

And with this way, in terminal, asked the pin number to me.

To reconnect the keyboard, each time I startup the PC, first turn on PC, and then press the side power button, and wait for 5 - 10 seconds. Now seems to be more stable


12-12-2016 . another episode in my AppleKeyboard life:

The same as I explained above, but

1- With Networking disabled

2- without asking the pin number to me, I typed the pin number "blind" when I see "Attempting to connect to ..."

1
  • I have the same problem on Ubuntu 16.10. As long as I pair apple magic keyboard A1644, a crash occurs. GDBus.Error:org.bluez.Error.ConnectionAttemptFailed: Page Timeout. In the directory you mentioned above "/etc/bluetooth", there is not a file named "hcid.conf". I don't know what I missed, could you help me? Thank you
    – Aoran Zhao
    Jan 23, 2017 at 20:14
0

just to improve a tad the answer here everything worked except I had to type

[bluetooth]# scan on  

just after

# bluetoothctl -a 

And then I followed through everything else and I could pair my Apple Keyboard.

Cheers!

1
  • 2
    should probably be a comment on the other answer
    – Zanna
    Jan 21, 2017 at 5:17
0

Final solution

After years without having a clear solution, I've realized that the connection happens when I access to the Bluetooth Drvices screen, and here, without touch the keyboard wait that keyboard disconnect and reconnect alone. this happens in 20 seconds aprox. but, very important: do not touch the keyboard during this process

When access to this screen, can pulse the keyboard power button to provoke this process, but only 1 time at the begining, then have to wait.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .