Since the upgrade from to Xubuntu 16.04 from Xubuntu 15.10 on a Lenovo Thinkpad Twist (S230u) with Broadcom wireless card the wlan0 device has disappeared. It is as though the physical device was inexistent. How can it be re-activated ?

During the last step of the upgrade process I clicked NO regarding the question whether I wanted to deactivate UEFI Secure Boot. (I don't know whether this is a useful information).

The system is currently up to date.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

--> finish with 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


--> only lists eth0 and lo.


--> contains a line "03:00.0 Network controller: Broadcom Corporation BCM43228 802.11a/b/g/n". But there is no mention of "wireless" or the like.


--> mentions eth0, wwan0, lo, each with no wireless extensions. Nothing else.

 nmcli -f all device show 

--> Same situation. GENERAL.DEVICE entries only for eth0, lo and cdc-wdm3 (which should be the mobile broadband device).


--> mentions under Additional drivers : Broadcom Corporation BCM43228 802.11a/b/g/n - Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary).

I tried the solution suggested by David Foerster. But the re-installation process finishes with an error. The situation remains as it is:

lspci -nn -d 14e4:
sudo apt-get purge bcmwl-kernel-source
sudo apt-get update
sudo apt-get update-pciids
sudo apt-get install bcmwl-kernel-source

The result is:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1 515 kB of archives.
After this operation, 8 013 kB of additional disk space will be used.
Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 259730 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.248+bdcom-     0ubuntu8_amd64.deb ...
Unpacking bcmwl-kernel-source ( ...
Setting up bcmwl-kernel-source ( ...
Loading new bcmwl- DKMS files...
First Installation: checking all kernels...
Building only for 4.4.0-21-generic
Building for architecture x86_64
Building initial module for 4.4.0-21-generic

Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.4.0-21-generic/updates/dkms/


DKMS: install completed.
modprobe: ERROR: could not insert 'wl': Required key not available
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.122ubuntu8) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-21-generic

Disabling validation via mokutil as described below didn't help either.

  • @Woozle I updated the answer.
    – Pilot6
    Apr 25, 2016 at 7:42

1 Answer 1


It looks like Ubuntu 16.04 does not install unsigned third party packages if Secure Boot is enabled.

You need to disable Secure Boot in UEFI settings to get wl work.

But that is a problem, because on some systems Secure Boot can't be disabled.

Update: This issue can be fixed. You can disable validation of modules by:

sudo apt-get install mokutil
sudo mokutil --disable-validation
  • I have a similar issue to OP's, except I have Realtek, not Broadcom, and my laptop is older than Secure Boot and UEFI. This is a real pain.
    – cat
    Apr 27, 2016 at 2:13
  • I disabled validation via mokutil, then rebooted. After purging bcmwl-kernel-source, I re-installed it. The result is still the same : "modprobe: ERROR: could not insert 'wl': Required key not available".
    – Woozle
    Apr 27, 2016 at 12:53
  • Maybe it is something wrong with you UEFI. Try to disable it there.
    – Pilot6
    Apr 27, 2016 at 13:44
  • Yes, thanks. After disabling SecureBoot in the BIOS the wlan interface was immediately available again.
    – Woozle
    Apr 27, 2016 at 16:30

Not the answer you're looking for? Browse other questions tagged .