15

I was on Ubuntu (vanilla, with Unity) 14.04 until yesterday, and since the new LTS version came out, I decided to go for an Ubuntu GNOME 16.04 clean install.

Since I installed Ubuntu GNOME 16.04 (64-bit), I have issues with the suspend mode (I did not have this problem on 14.04) on my Dell Inspiron 3537.

When I choose to suspend the session, the screen turns black, the fans go off for a few seconds (2 or 3 seconds), then they restart going faster and faster. I have to force shutdown (hold press power button) the computer to be able to restart it.

I did some research, and found out that Ubuntu 16.04 doesn't support the AMD Radeon proprietary graphic drivers. I don't know if it's related or not, but since I have an AD Radeon HD8850M, I ran an lspci | grep VGA and here is the result:

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus PRO [Radeon HD 8850M / R9 M265X] (rev ff)

Also, I have the open-source drivers installed:

$ sudo apt-get install xserver-xorg-video-ati
xserver-xorg-video-ati is already the newest version (1:7.7.0-1).

If you need any other information, please let met know.

19

19th July update: It seems like this bug was fixed upstream using kernel version 4.4.0-28-generic. I since migrated to ArchLinux, so this still needs to be tested, but there are people saying that it works with this kernel version on the launchpad bug.

Original post: It's seems that it is a 4.4.0 kernel bug, installing 4.4.8 solves the problem. You can either wait for a 4.4.0 kernel fix, or install the 4.4.8 kernel.

I recommand waiting for 4.4.0 fix, but i installed 4.4.8 and i've seen no problem whatsoever.

Execute following commands in order to install 4.4.8 kernel:

On 32-bit

Download

cd /tmp
$ wget \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.8-wily/linux-headers-4.4.8-040408_4.4.8-040408.201604200335_all.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.8-wily/linux-headers-4.4.8-040408-generic_4.4.8-040408.201604200335_i386.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.8-wily/linux-image-4.4.8-040408-generic_4.4.8-040408.201604200335_i386.deb

Install

sudo dpkg -i linux-headers-4.4*.deb linux-image-4.4*.deb

On 64-bit

cd /tmp
wget \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.8-wily/linux-headers-4.4.8-040408_4.4.8-040408.201604200335_all.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.8-wily/linux-headers-4.4.8-040408-generic_4.4.8-040408.201604200335_amd64.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.8-wily/linux-image-4.4.8-040408-generic_4.4.8-040408.201604200335_amd64.deb

Install

sudo dpkg -i linux-headers-4.4*.deb linux-image-4.4*.deb

Source : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1574125

I'll accept this answer in a few days if no better option shows up.

  • 1
    +1 for solving your own problem. This will help others that run into the same issue. – Zzzach... Apr 28 '16 at 8:07
  • Ubuntu security kernel upgrade to linux-image-4.4.0-22-generic 4.4.0-22.39does not solve the problem. – clapsus May 9 '16 at 6:08
  • Always check kernel.ubuntu.com/~kernel-ppa/mainline for new kernel releases. – Maduka Jayalath May 26 '16 at 18:05
  • Correct and thanks this fixed suspend issue. Going through the launchpad link there were more examples using even later kernels. – Enjoy87 Jul 14 '16 at 4:43
  • I updated my answer to say that is might be fixed using kernel version 4.4.0-28-generic. – clapsus Jul 19 '16 at 21:51
0

Upgrade to kernel 4.4.8 fixes my problem some months ago, but today I had to reinstall 16.04, this time before installing 4.4.8 I tested another solution and it's working: Adding some swap space.

I created a single swap file bigger than ram size, my ram size is 12GB and I have created a 16GB swap:

sudo dd if=/dev/zero of=/swapfile bs=1M count=16384
sudo chmod 600 /swapfile
sudo mkswap /swapfile
sudo swapon /swapfile

Now both suspend and hibernate are working with default kernel,

To enable swap file at boot, add this line to /etc/fstab

/swapfile none swap sw 0 0

For you info:

uname -a
Linux lena 4.4.0-64-generic #85-Ubuntu SMP Mon Feb 20 11:50:30 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Not the answer you're looking for? Browse other questions tagged or ask your own question.