9

i installed ubuntu 16.04 and installed nvidia-361 drivers that were shown as trusted drivers. but as i rebooted my system my system struck into login loop. i am using hp envy 15 series laptop with 740M graphics card. i looked for many questions over here and tried to mv ~/.Xauthority file to some backup place. This did not work. Then i tried reinstalling the nvidia-361 from the tty. but that also did not work.

what is the possible reason for the system to stuck in the login loop

what are the workarounds to solve this problem.

This problem is not about ./.Xautority or lightdm

3

2 Answers 2

6

I solved this problem. This problem was caused due to secure boot and EFI_SECURE_BOOT_SIG_ENFORCE in linux kernel 4.4.0-20 and later.

I installed the nvidia-364 drivers and entered the key when asked. Then i rebooted the system. when blue screen of mok management appeared i pressed any key to changed it. Then it asked for password characters. then it let me to disable it. i reinstalled the nvidia 364 after booting in insecure mode. and it worked like charm.

You may not need to do all the steps. Some people are saying you only need to disable the validation by running

sudo apt install mokutil
sudo mokutil --disable-validation

I did not try this because my problem was already solved.

Many people are not able to install virtual box modules due to the same implementation of EFI_SECURE_BOOT_SIG_ENFORCE.

You don't need to move ./.Xauthority file or change permissions of /tmp folder or do any another workarounds if you are affected by the same issue.As many people are saying these work arounds.

You can read here in detail https://wiki.ubuntu.com/SecurityTeam/SecureBoot.

3
  • So you have to disable secure boot? after you install the nvidia driver, did you try enable secure boot ?
    – aserww106
    Commented Apr 27, 2016 at 19:34
  • Not yet..but i will try if i find time. Enabling secureboot may prevent some modules to load . I am not sure about this. So i dont want to harm my development environment.
    – shiv garg
    Commented Apr 28, 2016 at 3:05
  • 4
    sudo mokutil --disable-validation output : EFI variables are not supported on this system Commented Jul 23, 2016 at 15:45
0

I had the same problem.

  • remove the old driver with the following command:

    sudo apt-get purge $(dpkg -l | awk '$2~/nvidia/ {print $2}')
    
  • reboot

  • install new driver:

    sudo apt-get install nvidia-340
    
2
  • even I install the nvidia-340 driver, still has this problem, and I even tried nvidia-364 open source driver, still no luck...
    – aserww106
    Commented Apr 26, 2016 at 18:15
  • use nvidia 361 as i stated in my answer
    – shiv garg
    Commented May 1, 2016 at 16:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .