3

I have made a fresh install of Kubuntu 16.04 via USB stick. The sha256 checksum of the USB stick matched the one on the download page. All installed packets have their most recent version. I have a AMD A10-7850K Radeon R7, 12 Compute Cores 4C+8G so I don't have a separate graphical card. On Kubuntu 14.04 I use the flgrx driver but this is no longer available on 16.06.

After I entered my password the blue progress bar reaches its end, but nothing happens anymore for 30 seconds. Then I get a pop-up with following message: "Plasma can not start. All shell packets are missing. This is related to the installation, please take contact with your distribution." (translated myself from Dutch). Then I get a black screen.

When pressing Ctrl + Alt + Delete I get the option to log out or to reboot.

Note: I have seen posts of other people having the same problem on other forums

  • See if entering a TTY (ctrl + alt + f1), logging in there and running sudo apt-get install --reinstall kubutu-desktop kde-* || sudo apt-get install -f helps at all. You'll have to be connected to the internet somehow. – TheWanderer Apr 24 '16 at 12:33
  • Thank you. I tried apt-get install --reinstall kubuntu-desktop: some extra packages are installed and now I can login. Problem solved ! – Frank Denissen Apr 24 '16 at 14:55
3

The problem seems to be that the Dutch translations (kde-l10n-nl) of KDE conflict with plasma-desktop. Forcing the reinstallation of plasma-desktop in a TTY fixed the issue. You don't have to reinstall kubuntu-desktop for this to work:

apt-get install --reinstall plasma-desktop 
apt-get -f install 
3

Some packages that are needed for KDE to run are missing or misconfigured.

Enter a TTY (Ctrl + Alt + F1) and log in there. Run sudo apt-get install --reinstall kubuntu-desktop kde-* || sudo apt-get install -f and KDE should start.

You'll have to be connected to the internet for this to work.

2

Actually, I had the same problem and it is related to the cached content. Just go down to the console with Ctrl + Alt + f1, log in, and:

~$ cd ~/.cache
~/.cache$ rm -rf *plasma* *kde*

exit - change back to the UI with: Alt + f7 (Usually) and log in through sddm again. Should work now.

The first login will take longer than usual - as it needs to rebuild all the caches. But apart from that - it's working.

Make sure you really log out out of GUI ! If not it won't really work.

1

There is another problem with Kubuntu, not only 16.04 with the plasma desktop on iMac running in Virtualbox. Using 3D acceleration in Virtualbox enabled will cause the toolbar of K Desktop becoming invisible. So there is a problem with the Virtualbox video drivers for Virtualbox OS X. Disabling 3D acceleration will solve this problem, but screen drawing is significantly slowed down and we want 3D acceleration to boost performance.

0
sudo add-apt-repository ppa:kubuntu-ppa/staging-misc 
sudo apt-get update
sudo apt-get install kde-l10n-nl
sudo apt-get install plasma-desktop
0

I just had the same issue. I tried some of the suggestions and got an interesting error. I found the fix as a result. The error was something to the effect that a /run/systemd/generator/home.mount could not be used that there was a duplicate in /etc/fstab. !!?? So I commented out all my extra drives, and voilla! NO idea yet why a mount command on an extra drive prevents xwindows to load, but that was it.

  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Sep 22 '16 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.