I've been having a lot of trouble fixing up the remains of my server after upgrading to Xenial yesterday.

PHP apps run as a mess of code, and ownCloud 'can't be found on the server' anymore.

It may be something to do with these errors I get when trying to run Apache2 from the command line.

After running systemctl daemon-reload'

I hope I can get some help on this, a lot of computers rely on this thing :/

I'd provide some more logs, but they are huge and I wouldn't know what parts to provide.

Oh, and I get this error when trying to install PHP5, if this helps.

When trying to install PHP5

Thanks in advance.

EDIT: Here's the output from running 'apache2' from the command line:

'apache2' command line output

  • 2
    16.04 runs with PHP 7.0 so if you want to get it working you might want to take a look here at the answer I provided. Feel free to leave an upvote if this helped you. – Videonauth Apr 24 '16 at 9:05
  • 1
    What are line 140 of /etc/apache2/apache2.conf and line 1 of /etc/apache2/mods-enabled/php5.load? Also, are you willing to use PHP 7.0? – Olathe Apr 24 '16 at 9:07
  • Thank you, I'll take a look. I'd be willing to use it if it offers the same compatibility and functionality, which I assume it does :) – Nectar Apr 24 '16 at 9:25
  • Line 1 is "LoadModule php5_module /usr/lib/apache2/modules/libphp5.so" while Line 140 is "IncludeOptional mods-enabled/*.load" – Nectar Apr 24 '16 at 9:27
  • 1
    Please don't post text as screenshot, instead copy the text and use the Markdown to post it as code. – oerdnj Apr 24 '16 at 10:06
up vote 26 down vote accepted

Ubuntu 16.04 comes with PHP 7.0. You need to install libapache2-mod-php package and then disable all traces of PHP5.

  1. Uninstall PHP5.x package: sudo apt-get purge php5-common (this will remove all PHP 5 packages.
  2. Install default (7.0) PHP apache2 SAPI: sudo apt-get install libapache2-mod-php
  3. If the apache2 is still broken do: sudo rm /etc/apache2/mods-enabled/php5.* to disable PHP5 mod and enable PHP 7.0 with sudo a2enmod php7.0.
  • 1
    Worked a treat, thanks. – Nectar Apr 24 '16 at 10:33
  • Fine, that helped me to resolve the problem I got after updating to the new version – Bultack May 6 '16 at 17:07
  • worked great on Linux Peppermint after the upgrade to 16.04 – Clain Dsilva Dec 14 '16 at 5:14

If you are running www from ~userdir/public_html, check the below in /etc/apache2/mods-enabled/php7.0.conf

# Running PHP scripts in user directories is disabled by default
#
# To re-enable PHP in user directories comment the following lines
# from <IfModule ...> to </IfModule>

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.