3

After booting an Ubuntu 14.04 Live from USB I connect to the internet everything works great for a few seconds, then the internet stops working. It doesn't say it's disconnected or anything like that, but webpages won't load, sudo apt-get update can't connect.

My internet access is fine, I am able to stream music on my tablet while using the Live USB. The installed OS on my laptop is Windows 10 and I have no problem accessing the internet from there.

I tried this with both Live Ubuntu and Linux Mint ISO images loaded from an USB stick.

For the initial couple seconds that the internet works after connecting to my WiFi, pages load quickly. If I connect to a second network, it works again for a few seconds, but then stops as before.

EDIT: I've tried pinging my router's IP from the command line immediately after connecting, and the packages are received as expected for a short while, but then suddenly stop.

The output of lspci -nn | grep Network:

0d:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
  • With network and internet problems I think the first thing you should do is check if you can reach your router ping <router_ip_address. After that try to ping some IP address ping 8.8.8.8 for example. After that, try to ping a internet page, for example ping www.google.com. I recently saw a question about browser in ubuntu didn't working but the internet connection working correctly. – migrc Apr 27 '16 at 12:32
  • I forgot it. Could you post on your question the output of the ifconfig command? If possible before and after the problem takes place – migrc Apr 27 '16 at 12:39
1
+50

Your chipset from Realtek is badly supported, a quick Google search shows lots of similar problems under linux.

A driver for your chipset is available on Github. You would need to download it and compile it yourself. Install build-essentials , download the zip archive and compile the driver in the rtl8188ee folder with the classic ./configure, make and sudo make install.

  • I tried pinging my modem's IP, and had 100% packet loss. I did this with Ubuntu 16.04 – Trae Apr 28 '16 at 11:42
  • So, it looks like your hardware is supported by neither older nor younger linux drivers. Without hardware information, difficult to give more advice. – emk2203 Apr 28 '16 at 11:48
  • How do I install build-essentials when I can't connect to the internet in the first place? – Trae May 1 '16 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.