1

"connection.gateway-ping-timeout: cannot set property: value of "###" of type 'guint' is invalid or out of range for property type 'gateway-ping-timeout' of type 'guint' "

"###" is sometimes a different value and sometimes repeating.

Also reported here

Found a bug report here

This is new to 16.04. If a fix is not available, a workaround would help too.

4

I had this very same issue with connection.gateway-ping-timeout. Forcing a value different from default 0 from a shell worked for me:

nmcli c modify "Wired connection 1" connection.gateway-ping-timeout 10

I was then able to configure a manual IP address from the KDE Connection Editor.

| improve this answer | |
  • It looks like it does allow for a single edit to be completed through the connection editor, at least after a few tries which is enough of a workaround. – K. Eoe May 3 '16 at 1:30
  • Could add what to do if the desired network does not show up in the connection editor and thus nmcli does not find the network name? For wireless connections ofc – idkfa May 4 '16 at 11:00
0

John`s tip helped me.

I had a similar problem. I was able to create a VPN-connection through import *.ovpn file. But after the connection was add, I was not able to edit it in the Network Manager. I have completed:

nmcli connection modify "<VPN-connection name>" connection.gateway-ping-timeout 100

Then I open the properties of VPN-connection and disable ipv6 support. After that I was able to make any changes in this connection and it worked.

| improve this answer | |
  • Is there a way to set that as a default for all network connection types? I am getting that error message on creation of the vlan and it never finishes the creation of the connection for me to do that – Kendrick Dec 30 '16 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.