1

I installed kde with sudo apt-get install kde-full on my ubuntu 14.04 desktop, then I got a warning about running out of space (I can't remember it exactly) and kde was still installing so I killed the process and tried to uninstall it but it wouldn't let me as a process was still running? Anyway I rebooted the computer and it now boots to the kdm login screen which accepts my username and password but then nothing loads, I just have the kdm wallpaper and a cursor.

I have seen it's something about lightdm but how can I change to this?

  • There should be a menu on the login screen to change which desktop environment you want to use. Make sure Ubuntu Desktop is selected and not KDE. When you log in, run sudo apt-get purge kde-* kubuntu-*. – TheWanderer Apr 23 '16 at 18:52
  • I selected ubuntu but its still not loading anything. Can I do the purge via the ubuntu recovery mode "drop to shell" option? – mmm Apr 23 '16 at 18:53
  • It would be better to try a TTY: ctrl + alt + f1, log in here, run the command above, then run sudo apt-get install --reinstall ubuntu-desktop – TheWanderer Apr 23 '16 at 19:04
  • Thankyou! I got it all back!! I was having major panics as I have some unbacked up PhD work on that computer and I feared I'd never see it again. – mmm Apr 23 '16 at 19:18
  • Oh, there was definitely no data loss. You'd just be left with no GUI :p. – TheWanderer Apr 23 '16 at 19:27
0

KDE is huge, so it's not very surprising that you ran out of space. Next time, though, try to resolve before you reboot. It can save you a lot of headache.

Follow these steps to restore normal Unity.

  1. Enter a TTY by pressing Ctrl + Alt + F1.
  2. Log in with your username and password.
  3. Run sudo apt-get purge kde-* kubuntu-*.
  4. Run sudo apt-get install --reinstall ubuntu-desktop.
  5. Reboot.
  6. You should be back to LightDM, and Unity should start when you log in.
    • Make sure that Ubuntu Desktop is selected in the menu at the top right of the password box. If this menu doesn't exist, that's fine. Just log in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.