4

I am using vagrant to run some virtual machines on my personal laptop (Windows 10).

I have already installed ubuntu 14.04 and centos on this laptop and all works as expected.

Today I tried to install the new box for ubuntu 16.04 and I simply executed:

vagrant init ubuntu/xenial64; vagrant up --provider virtualbox

After a few seconds the virtual machine was up and vagrant wrote the following message:

A Vagrantfile has been placed in this directory. You are now

ready to vagrant up your first virtual environment! Please read

the comments in the Vagrantfile as well as documentation on

vagrantup.com for more information on using Vagrant.

Bringing machine 'default' up with 'virtualbox' provider...

==> default: Box 'ubuntu/xenial64' could not be found. Attempting to find and install...

default: Box Provider: virtualbox

default: Box Version: >= 0

==> default: Loading metadata for box 'ubuntu/xenial64'

default: URL: https://atlas.hashicorp.com/ubuntu/xenial64

==> default: Adding box 'ubuntu/xenial64' (v20160420.3.0) for provider: virtualbox

default: Downloading: https://atlas.hashicorp.com/ubuntu/boxes/xenial64/versions/20160420.3.0/providers/virtualbox.box

default: Progress: 100% (Rate: 2648k/s, Estimated time remaining: --:--:--)

==> default: Successfully added box 'ubuntu/xenial64' (v20160420.3.0) for 'virtualbox'!

==> default: Importing base box 'ubuntu/xenial64'...

==> default: Matching MAC address for NAT networking...

==> default: Checking if box 'ubuntu/xenial64' is up to date...

==> default: Setting the name of the VM: ubuntu-xenial-16.04-cloudimg

==> default: Fixed port collision for 22 => 2222. Now on port 2200.

==> default: Clearing any previously set network interfaces...

==> default: Preparing network interfaces based on configuration...

default: Adapter 1: nat

==> default: Forwarding ports...

default: 22 (guest) => 2200 (host) (adapter 1)

==> default: Running 'pre-boot' VM customizations...

==> default: Booting VM...

==> default: Waiting for machine to boot. This may take a few minutes...

default: SSH address: 127.0.0.1:2200

default: SSH username: ubuntu

default: SSH auth method: password

default:

default: Inserting generated public key within guest...

default: Removing insecure key from the guest if it's present...

default: Key inserted! Disconnecting and reconnecting using new SSH key...

==> default: Machine booted and ready!

==> default: Checking for guest additions in VM...

As you can see, because I had already another VM running (that I cannot stop), vagrant used a different port for ssh instead of the default 2222.

When I tried to access the server with putty, I got the following error:

Disconnected: Server protocol violation: unexpected SSH2_MSG_UNIMPLEMENTED packet

I know that I can access the VM using "vagrant ssh". I have already done it, but given that I am on windows, I would prefer to use putty.

EDIT I stopped the other virtual machine and restarted the xenial box that now is using the defaul port, but I still get the same error.

3
  • Try.... Putty config go in Connection->SSH->Kex Change - Max minutes before rekey to 0 - Max data before rekey to 0
    – user508889
    Apr 23, 2016 at 18:46
  • @Brian - I tried but it did not work. Apr 25, 2016 at 13:40
  • To anyone who down voted the question: it would be nice to say why... Apr 25, 2016 at 13:41

1 Answer 1

3

I experience the same problem when I try to access Ubuntu 16.0.4 LTS Server, clean install with only OpenSSH selected as additional software. I was using an old 2013 version of PuTTY.

This problem went away when I downloaded and used the "PuTTY Latest Development Snapshot".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .