5

I have a new System76 Lemur Laptop. It worked fine for a week. I installed Kubuntu, it worked fine. Then I upgraded to Kubuntu 16.04 LTS and the system doesn't boot fully anymore. The Kubuntu logo flashes but then never displays the login UI, I just see black. I can get a TTY by pressing CTRL+ALT+F1 key. I can run startx -- :1 from the TTY to get a bare bones graphical interface.

How can I get a usable graphical interface?

2
  • 1
    It didn't work after the first long tty, then I rebooted holding down shift and chose the latest os recovery; fixed broken pkgs and rebooted. It worked! – user559625 Jun 21 '16 at 14:00
  • Same here. I start to hate K/Ubuntu! After every update/upgrade something essential is broken and the user is left with a blinking cursor... These are the moments when I regret to have switched to free and open (but crappy and broken) software :( – Sliq Dec 1 '16 at 20:16
7
sudo dpkg-reconfigure sddm

and selecting sddm worked for me.

2
  • Worked for me. I guess @Enkouyami's answer is a bit more hard-core approach, if above fails. – Aleksandar Pavić Mar 2 '17 at 20:47
  • 2
    Take care: in my case this messed up my whole system! Needed to start the rescue console ... -1 – Trinimon May 23 '17 at 18:15
5

Run

sudo apt-get install --reinstall kubuntu-desktop plasma-desktop plasma-desktop-data sddm xorg xserver-xorg-core xserver-xorg-video-intel && sudo dpkg-reconfigure sddm

The 1st part will reinstall kubuntu's KDE plasma, the X11 display server, the sddm display manager, and the intel video driver; the next will allow you to set it as the default display manager. If some of those packages aren't installed, it will attempt to install them.

Logs are located at /var/log. Look for the log for Xorg and sddm.

6
  • Ok @DavidFoerster, I have clarified my position. – Enkouyami Apr 23 '16 at 22:30
  • Thanks, but this didn't work. I still see the same problems. Is there some debug log that I should look at that might offer some clues? – rrenaud Apr 25 '16 at 2:10
  • 1
    @rrenaud Run sudo apt-get install --reinstall sddm; sudo dpkg-reconfigure sddm to reinstall & configure the sddm display manager. Logs are located at /var/log/ and look for the ones for sddm and Xorg. – Enkouyami Apr 25 '16 at 3:44
  • Also, could you make a bug report using ubuntu-bug xorg? You will probably get a lot more help than you could from askubuntu. – Enkouyami May 1 '16 at 22:42
  • 2
    Reconfigure of sddm without reinstall worked for me. – musiKk Jul 1 '16 at 10:11
1

Note - This message only aims at proprietary nvidia drivers users. I'm not sure if your laptops has one, but it may help for other people that were in the same situation. :

I just encountered a similar issue after updating my Kubuntu 16.04 setup (it already worked fine with it). Messing around KDE packages didn't help. However I noticed that Plasma was actually working but I didn't get any real visual feedback (right click worked as if plasma was properly started). I could start in a konsole using alt+f2 and blindly launching it. Manually restarting KWin (kwin_x11 --replace) showed me that compositing got disabled because of the lack of GLX extension in the X server. It was confirmed by glxgears not willing to start.

So I dropped in a TTY, logged in, sudo service lightdm stop (note : the default DM under Kubuntu is sddm so it most likely would be sudo service sddm stop), reinstalled the nvidia drivers, rebooted and it was back working.

I wonder if it was just about the X.org config (so try messing around nvidia-xconfig first) that got replaced or if the upgrade nuked up some GLX libraries.

Hopefully this will help you and some others going by!

1
  • 2
    The system76 lemur laptops use Intel integrated graphics. – Enkouyami May 1 '16 at 22:36
-1

Same problem. I held the shift key down during boot and got to a menu where I chose "advanced options," then selected "upstart." At least I can do my office work now. Unknown how to make systemd, the new type of booting up, function.

Not the answer you're looking for? Browse other questions tagged or ask your own question.