1

I have Virtualbox 4.3.36 on Ubuntu 14.04.

I am Trying to make a NAT network work, but I can not start it using VBoxManage, I get this message:

VBoxManage natnetwork start --netname NatNetwork
VBoxManage: error: Code NS_ERROR_FAILURE (0x80004005) - Operation failed (extended info not available)
VBoxManage: error: Context: "Start(Bstr("whatever").raw())" at line 449 of file VBoxManageNATNetwork.cpp
VBoxManage: error: Failed to start network

If I start a virtual OS, this one gets a correct IP & gateway from the DHCP server on the NAT network, but it can not ping the gateway, nor the DHCP server, nor the outside world.

I tried several NIC types, but the outcome is always the same. Tried creating/starting the NAT network both with vBoxManage as well as the GUI, but with the same results.

There is no problem if I set the network type to NAT, but I would like to have some virtual machines to be able to communicate to each other & the outside world.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.