18

After upgrade to Ubuntu 16.04, Steam doesn't start. When I execute it from the command line, I get the following error:

$ steam
Running Steam on ubuntu 16.04 64-bit
STEAM_RUNTIME is enabled automatically
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
Installing breakpad exception handler for appid(steam)/version(1459463254)
  • After sudo ldconfig? – Karl Richter Apr 23 '16 at 12:05
  • now it seems to work after reinstalling the nvidia driver – Senpai Apr 23 '16 at 12:30
24

I upgraded from 14.04 LTS to 16.04 LTS and also wasn't able to start Steam. It started (I mean, 'steam' continued to be running), but nothing happened after a few seconds.

For me, the workaround I finally found was to run Steam from commandline with:

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' steam

Non-essential information below.

Steam provides essentially a "mini distribution" with it, called Steam Runtime, but it isn't currently doing a complete job so it somehow clashes with system C++ standard library and/or other libraries. During my experiments I had also a complaint of system libreadline6 <-> Steam runtime libtinfo5. After I manually unpacked the steam runtime tarball package under the Steam directory to overwrite what I previously had there, it changed to be as described in this problem (pcre_jit_stack_alloc).

An interesting tidbit is that before I found the solution above, I was able to start Steam so it downloaded an upgrade for itself by disabling the Steam Runtime temporarily with export STEAM_RUNTIME=0. Steam itself wouldn't run but that was my first step forward. I tried installing system equivalents of the 32-bit libraries required, but didn't finish / get it working.

  • This fixed it for the first launch. Then, for the second launch, I get the same error. – Michael Fayad Nov 5 '16 at 16:27
7

Executing the following command works everytime for me.

LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /$LIB/libgpg-error.so.0' steam
  • This worked for me on Debian Stretch. Thank you! – Alois Mahdal Jan 10 '17 at 5:37

protected by Community Aug 29 '16 at 20:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.