3

In 15.10, both internal Intel and external USB audio were working. After upgrading to 16.04, USB audio has stopped working but Intel remains functional. Any ideas?

The /etc/modprobe.d/alsa-base.conf modifications:

# options snd-usb-audio index=-2  # comment out the default setting
options snd-hda-intel index=0,2 model=dell-m6-amic
options snd-usb-audio index=1 vid=0x1235 pid=0x800a

There seem to be two issues:

  1. After boot, lsusb is no longer listing the USB soundcard.

  2. If the soundcard is manually re-plugged in, pulseaudio killed, and alsa force reloaded, it does show up in lsusb but still does not show up in Sound Settings (only on board sound working). In this case, the following debug info is available:

$ lsusb

ID 1235:800a Focusrite-Novation Scarlett 2i4

$ cat /proc/asound/cards

0 [PCH            ]: HDA-Intel - HDA Intel PCH
                  HDA Intel PCH at 0xd2710000 irq 33
1 [U0x12350x800a  ]: USB-Audio - USB Device 0x1235:0x800a
                  USB Device 0x1235:0x800a at usb-0000:00:14.0-4, high speed

$ cat /proc/asound/modules

0 snd_hda_intel
1 snd_usb_audio

$ lspci -v | grep snd

Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

$ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: U0x12350x800a [USB Device 0x1235:0x800a], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
  • As far as ALSA is concerned, it's there. This sounds like a PulseAudio problem. – CL. Apr 23 '16 at 17:40
  • 1
    It is same to my case. see this It was solved and more stable. – nakasya May 2 '16 at 0:58
  • Thank you very much @nakasya , I was very confused about this problem! I added an answer pointing to your link. – neutreno May 3 '16 at 3:42
5

The problem turned out to be more complicated than originally thought and kept re-appearing on reboot.

Thanks a lot to @nakasya for pointing out that it's a bug in fwupd that appeared when upgrading to Ubuntu 16.04. Refer to Problems with Audio device (ALC-889) - Ubuntu 16.04 .

The temporary workaround until the fix is included in the main release is to run sudo killall fwupd and reconnect the USB audio device.

  • This also seems to be a problem in Fedora 24. This solution fixed it for me. – Jared Mackey May 31 '16 at 4:33
1

You cannot have more than one options line for the same module.

The first two indexes are taken by the two HDA devices, so it is not possible to force the USB device to have index 1.

To move the second HDA device to the third index, use something like this:

options snd-hda-intel index=0,2
  • Thanks for the speedy reply @CL. ; I applied your advice, and things are looking a bit better, but sadly USB audio is still not working. I have updated my question to reflect the new info. – neutreno Apr 23 '16 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.