I've just installed a new ubuntu 16.04 ,
fresh install clean , logged in the first and only thing i did is selecting the proprietary driver 361 for nvidia , rebooted the machine .
anfter rebooting i can login but unity isn't showing , i can still right click though and open terminal , tried many answers:
link1 link2

did not help , i got frustrated , booted into usb and freshly installed it again, this time i tried 340 drivers same problem .
i mean this is 16.04 LTS for gods sake .
i have dual grahpic cards nvidia gt 740m , intel built on ASUS laptop .

output of grep "EE\|WW" /var/log/Xorg.0.log :

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    23.758] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    23.761] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[    25.323] (WW) Unresolved symbol: fbGetGCPrivateKey
[    25.448] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[    25.613] (WW) modeset(G0): Option "AllowEmptyInitialConfiguration" is not used
[    25.613] (WW) modeset(G0): Option "IgnoreDisplayDevices" is not used
[    25.902] (EE) NVIDIA(0): Failed to initiate mode change.
[    25.902] (EE) NVIDIA(0): Failed to complete mode change
[    26.214] (WW) evdev: SteelSeries Sensei Raw Gaming Mouse: ignoring absolute axes.
[    26.216] (WW) evdev: SteelSeries SteelSeries Apex Raw Gaming Keyboard: ignoring absolute axes.
[    26.272] (II) XINPUT: Adding extended input device "USBest Technology SiS HID Touch Controller" (type: TOUCHSCREEN, id 16)

full log file LOG

xorg.conf file :

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"

Section "Screen"
    Identifier "intel"
    Device "intel"

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:4@0:0:0"
    Option "ConstrainCursor" "off"

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
  • What does grep "EE\|WW" /var/log/Xorg.0.log show?
    – Hi-Angel
    Apr 23, 2016 at 10:43
  • @Hi-Angel i have updated the answer with the output Apr 23, 2016 at 10:58
  • From the part Option "IgnoreDisplayDevices" is not used I'd guess that you have xorg.conf file somewhere. I'd try first to move it somewhere, e.g. to a home directory, to see if it fixes the problem. It is most probably in /etc/X11/xorg.conf. If it's not there, you can see the path by executing the command grep "Using config file" /var/log/Xorg.0.log.
    – Hi-Angel
    Apr 23, 2016 at 11:12
  • @Hi-Angel it was in /etc/X11/xorg.conf and tried copying it to ~/ , didn't help :/ Apr 23, 2016 at 11:19
  • No, not copying, I mean move it somewhere, i.e. make a backup, and remove it in the original directory :)
    – Hi-Angel
    Apr 23, 2016 at 11:20

8 Answers 8


I also installed Ubuntu 16.04, clean install on a new hd and everything worked fine until I switched to NVIDIA driver. After rebooting I couldn't get past the login screen. The solution that worked for me was to disable secure boot.

While stuck in login loop, I switched to console Ctl+Alt+F1, rebooted and disabled secure boot in UEFI. Now everything works with nvidia driver installed.

  • Yes, your solution worked for me. I have never expect that UEFI + nvidia can caused an error of this type!
    – King Midas
    May 13, 2016 at 18:19
  • In addition to disabling secure boot we had to switch from "UEFI+CSM" to "UEFI" and then we were able to boot fine.
    – Haluk
    Aug 24, 2016 at 12:17
  • You dont have to disable secure boot to use nvidia drivers askubuntu.com/questions/761886/…
    – QkiZ
    Sep 19, 2016 at 13:05

I had this problem too. I just run this in a console (press Ctrl + Alt + F1, in login page to show first virtual tty):

sudo apt-get purge nvidia*

After this, rebooted and then i could login. After that, I installed intel drivers first, and then nvidia-361.

These were the steps I followed:

  1. sudo apt-get purge nvidia*
  2. reboot (now I had noveau display driver working)
  3. sudo apt-get install intel-microcode
  4. sudo apt-get install intel-gpu-tools
  5. Reboot (for testing, everything was working fine)
  6. sudo apt-get install nvidia-361 (I think nvidia-current is better long term option).
  7. Reboot

Now I have these (sorry they are in spanish):

Additional drivers

  • What do you mean by installing intel drivers ? Apr 23, 2016 at 18:03
  • 1
    Just edited the answer to show the steps I followed. Hope, this can help.
    – Shosta
    Apr 23, 2016 at 18:28
  • For others: I had this with 18.04 after swapping graphics cards then back. Simply the first step worked (purge nvidia) then reboot, uses default driver, search for proprietary ones, finds nvidia, use that, the end.
    – dez93_2000
    May 25, 2018 at 6:13

I also have an issue with 16.04 and Nvidia 361.42 driver. You can use prime-select intel or Nouveau driver as temporary workaround. I have had endless issues with the official Nvidia Ubuntu drivers over the years, it's very hit and miss. I thought the introduction of Steam OS and the growing number of Linux users/gamers might encourage them to better support Linux :/


Found the solution (this time for real),
i decided to be an ubuntu expert , so i went to google and typed :

debug ubuntu

then it gave me the page Debug and i selected unity .
in some part i needed to do :

$ unity --advanced-debug
GNU gdb (GDB) 7.2-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:


(gdb) set logging file unity.log
(gdb) set logging on
(gdb) b _exit
Function "_exit" not defined.
Make breakpoint pending on future shared library load? (y or [n])
[Answer yes (y)]

(gdb) run

[ and when compiz/unity crash, do...]

(gdb) bt full

[ then CTRL-D or re-run compiz to continue working ]

(gdb) run

after running this i noticed the error :
compiz (core) - Error: Plugin 'opengl' not loaded.

i searched for this error on google and it gave me this thread Unity missing? Can't see top or side panels , the answer here works .


I think I have found the solution. I have had terrible trouble with installing 16.04 on my main machine. Nvidia drivers crash and you can't log in and you have to resort to sudo apt-get purge nvidia-*. Chrome was crashing.

I have had no trouble with my secondary machine which has a traditional bios. It is only my main machine with UEFI firmware. The most frustrating thing is that I had been running 16.04 from a daily build for some months and it was rock solid.

I have noticed that the installer asks for a password if you download drivers as you install. The solution is to TURN OFF SECURE BOOT. Installing Ubuntu (from the UEFI option in the Bios Menu) then proceeds faultlessly and the system seems stable. 16.04 is not perfect e.g. to install Chrome you have to use gdebi, but at least it is now useable.


For me the solution after lots of searching was to disable UEFI in the BIOS. My machine runs only Linux so disabling UEFI was not a big deal.

I was having problems with VirtualBox and NVIDIA and could not get either to work with Ubuntu 16. I was seaching for "ubuntu 16 UEFI Virtual Box Fail kernel build" and came across a link regarding Virtualbox that made me wonder about UEFI and disabling it.

After disabling UEFI I reinstalled Ubuntu 16. During the install the dialog box that had the "Secure boot" entry was devoid of that content.

I'm happy to report that Ubuntu 16 is running and I'm having no problems with either NVIDIA or VirtualBox! Both are working as expected.

Thanks to those that shared their knowledge so I could move forward.


Ubuntu 16.04 comes with xserver Xorg 1.18 and the configuration is a little bit different than previously. In a dual GPU setup, from Arch Linux wiki, the /etc/X11/xorg.conf should be like this:

Section "Module"
    Load "modesetting"

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "AllowEmptyInitialConfiguration"

Replace PCI:1:0:0 for your nvidia Bus ID. You can check it with:

$ lspci | grep -E "VGA|3D"

It works for my HP laptop with dual GPU: Intel (Skylake) and NVIDIA 940m. Remember it's possible to switch between them with prime-select command (as root) or nvidia-settings official application and reboot your computer.


I had a similar problem, but my issue in particular was caused by the ESET NOD32 Antivirus.

The driver installation, both from the ubuntu repos and the manual NVIDIA driver installation was getting stuck building the DKMS modules.

I found instructions on how to uninstall ESET and after uninstalling, I set my run-level to 3:

sudo systemctl enable multi-user.target
sudo systemctl set-default multi-user.target

Blacklist nouveau:

Edit /etc/modprobe.d/blacklist.conf as super user and add:

blacklist nouveau

Then purge NVIDIA and reboot:

sudo apt purge nvidia*
sudo reboot

Once in run level 3, I manually installed the latest NVIDIA driver, set the run level back to 5 and rebooted.

sudo sh ./NVIDIA...
sudo systemctl enable graphical.target
sudo systemctl set-default graphical.target

Things were finally working, so I re-installed the Antivirus. Will have to wait for a kernel update to ensure that the NVIDIA driver gets rebuilt then.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .