1

Works fine with opensource drivers, but with catalyst flickers everytime you press on activities or the lower right bar.

I have 01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3600 Series

Running fresh ubuntu 11.10 and catalyst 11.10 from ati.com website.

Any suggestions?

EDIT: I want to use the proprietary drivers I know that opensource ones work fine.

5

4 Answers 4

1

This steps worked for me and what you probabably should do is upgrade you ATI drivers. They have solved a lot of those issues you're facing on.

http://www.upubuntu.com/2011/12/how-to-install-amd-catalyst-1112-linux.html

For smooth installation, it is recommended to uninstall currently availabe Catalyst driver. To do this, use these commands from the terminal:

sudo apt-get remove fglrx*

To install the AMD Catalyst 11.12 Linux driver now on Ubuntu 11.10 (32-bit & 64-bit) or any older version, run this sequence of commands:

cd ~/;
mkdir catalyst11.12; 
cd catalyst11.12/

wget -O ati-driver-installer-11-12.run http://www2.ati.com/drivers/linux/ati-driver-installer-11-12-x86.x86_64.run 

If you have a 64 bit system, then install this before anything

sudo apt-get install ia32-libs

After that you can start installing the new ati driver:

chmod +x ati-driver-installer-11-12.run 

sh ./ati-driver-installer-11-12.run

Make now an update for the X.org file with this command:

sudo aticonfig --initial -f

sudo reboot

Hope this helps.

1

Uninstall proprietary drivers.

I did it last week and latest version of open source drivers works perfectly.


sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
sudo rm -rf /etc/ati

2
  • I know that opensource one works, I need proprietary ones. Nov 6, 2011 at 18:48
  • If the open source driver works, but the proprietary one does not, I highly suggest you file a bug report with ATI. Support for closed source drivers is fairly minimal and does not typically extend beyond installation and configuration.
    – Panther
    Apr 2, 2012 at 17:35
0

try to remove Screenlets if you have ones, it helped for me (Ubuntu 11.10, AMD Proprietary Drivers 11.10).

1
-3

To solve this (with propietary drivers) install compiz manager, then go to OpenGL and make sure all the options are unchecked. Restart and you are good to go (:

2
  • 1
    As I stated I'm using gnome-shell not Unity. Gnome-shell doesn't use compiz. Nov 6, 2011 at 20:17
  • oh, that's a problem, sorry I couldn't help you ;D
    – victorhqc
    Nov 26, 2011 at 5:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .