11

Since I have an onboard Intel graphics card, and a ATI Radeon display controller, I was wondering if I could switch between the two as my graphics in use, as I could in 14.04 LTS through ATI Catalyst?

16.04 LTS is using the onboard, and the hardware listing lists ATI as well as display controler, but not in use. Additional drivers don't provide anything.

So is AMDGPU being used, or is ATI disabled?

lspci:

00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev ff)

lspci -nnk | grep VGA -A1

00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09)
    Subsystem: Lenovo Broadwell-U Integrated Graphics [17aa:3824]
20

To use the AMD Graphics card, execute this command:

DRI_PRIME=1 ./executable

If you want to run a Steam game with AMD Graphics Card, you should set the Game Launch Options on Steam with this command:

DRI_PRIME=1 %command%

To test manually if this is working, you can execute this:

glxinfo | grep "OpenGL renderer"

This command will show your Intel Graphics Card. Execute this command to see your AMD Graphics Card:

DRI_PRIME=1 glxinfo | grep "OpenGL renderer"

For example, in my case, when I execute glxinfo | grep "OpenGL renderer", my output is this: OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile

But, when I execute DRI_PRIME=1 glxinfo | grep "OpenGL renderer", my output is like this: OpenGL renderer string: Gallium 0.4 on AMD CAPE VERDE

There are other commands to test, If you want more tests:

glmark2 (use intel) and DRI_PRIME=1 glmark2 (use AMD)

| improve this answer | |
  • My notebook is an MSI GX60 3AE with a A10-5750m APU (integrated 8650G) and a 7970m GPU. I've installed Ubuntu 16.10 today. The APU seems to work with the default driver. It has some tearing-effects while browsing but it can play 1080p @60 in the browser, light gaming like minecraft works well and the temps are quite low. So I'm happy with that. But the 7970m doesn't kick in while gaming. That's sad =/ The DRI_PRIME=1 command shows the same result: Gallium 0.4 on AMD ARUBA (DRM 2.46.0 / 4.8.0-39-generic, LLVM 3.8.1). Any ideas? Until now I tried to install the Oibaf drivers. – ecth Mar 5 '17 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.