After successfully upgraded to 16.04, I am now getting this message whilst booting
lvmetad not active yet, using direct access

  • I have a similar problem - this message appears briefly after logging in to the desktop. And then I get thrown back to the log-in screen. Console access (e.g. Ctrl+Alt+F6) works OK. I've hunted around a little: - tried removing .Xauthority. No benefit - tried apt-get install xubuntu-desktop, and apt-get autoremove. No benefit (although the log-in screen is different)
    – Chrisky
    Apr 23 '16 at 9:37
  • Unlike Chrisky I am unable to login at all. After grub I get the same mesage as Kitcho lvmetad not active yet, using direct access. I can not execute any command. My root partition was lvm.
    – Torrien
    Apr 24 '16 at 0:40
  • Please flag the question as a duplicate Oct 13 '16 at 1:42

This is an inofensive message and you should not worry about it.

If you do 'man lvmetad' you'll find that it is a daemon that caches disk metadata. If this daemon is not available, lvm will read the metadata from the disk. This may be a problem with very complex systems with hundreds of volumes, but it is not for a desktop.

Every message that says it has been solved by touching grub or after installing some packages, has probably solved by upgrading the system and recreating the grub configuration.

This is a very very low priority bug and was there in Ubuntu and Debian for a while. Probably will dissapear in a upgrade without doing anything.

I've got that message for a while and without any adverse condition.

People complaining to be unable to login are being affected by another error and should continue checking the logs to find it.


Thanks to @Kyle in this thread, you can stop this blocking your interactive ttys from appearing with the following:

I managed to resolve this for my machines by adjusting the grub configuration like so:

In /etc/default/grub, change:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" Then add this line: GRUB_TERMINAL_INPUT="console serial" Run sudo update-grub and reboot for the changes to take effect.

  • This just sends logs somewhere else, maybe impacting useful log reporting. Solves nothing regarding what is being logged. Sep 26 '18 at 22:23
  • In the thread you mention they solve a video issue by enabling nomodeset, it is absolutely unrelated to the messages. Sep 26 '18 at 22:28
  • You are correct, but the I believe the problem OP is experiencing is absolutely unrelated to the messages, beyond the messages appearance being a symptom. The problem is that the TTY this message appears in is non-interactive (ie the user cannot login). What I believe OP is asking for, is an interactive tty to appear immediately instead of having to manually switch to one using ctrl-alt-f[1-7] every time they boot. Now, fair enough I may be reading more into the issue than required, however this question ranked highly in the google results when I was trying to resolve the issue detailed
    – cleary
    Oct 3 '18 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.