I recently upgraded to Ubuntu 16.04 and have been having issues connecting to the internet. I can use it for a few minutes and then all of a sudden pages stop loading and I get the "server not found" message on Firefox. Ubuntu still shows it's connected to the internet, though. If I disconnect and reconnect the cable, or even just click on "wired connection 1" in the menu, it reconnects and the internet works again for a short time. I have to do this every few minutes. Does anyone know what the problem could be? Or how to solve it?

I've tried reinstalling ubuntu from fresh but the issue is still there. I've also had a bunch of other problems (graphics), but I'm hoping I'll be able to fix them once my internet is 100% working.

If it's of any help my rig is:

  • Ubuntu 16.04 (alongside Windows 10)
  • Intel i7 6700 CPU
  • Gigabyte H170M-D3H motherboard
  • ASUS Nvidia GeForce GTX 750 ti GPU

Any help would be greatly appreciated. I've pretty much tried everything I can find on the net.

  • Hi. To help diagnose the problem, can look into /var/log/syslog at the time when your connection seems to drop ? – alci Apr 23 '16 at 6:40
  • 1
    I typed that into Firefox and a whole huge page of text came up...not sure how much is necessary but I'll copy some of it below: Apr 23 16:03:59 Chris-PC avahi-daemon[795]: Withdrawing address record for fe80::f910:2ff3:14a3:675b on enp0s31f6. Apr 23 16:03:59 Chris-PC avahi-daemon[795]: Registering new address record for 2408:212:66cb:6e00:d189:6c44:7f3b:91cc on enp0s31f6.*. Apr 23 16:07:01 Chris-PC whoopsie[813]: [16:07:01] Cannot reach: daisy.ubuntu.com Apr 23 16:07:01 Chris-PC whoopsie[813]: [16:07:01] offline – Chris Apr 23 '16 at 7:10
  • I'm not sure what exactly you did, but you need to open a terminal with CTRL+ALT+T and then type tail /var/log/syslog which will show you the last few lines of the msgs. Or you could do cat /var/log/syslog | grep "eth" | tail -50 to see an in-depth view of the ethernet. – AzkerM Apr 23 '16 at 7:28
  • Thanks! I'm no pro at linux so know what to type and where is a little beyond me. I tried typing it into terminal with "no command found" so tried it in Firefox and that's what I got. Just tried your suggestion in terminal and got a similar list of things. I can't paste it on here though as it is over the allowed character length. Is there another way I can post it? – Chris Apr 23 '16 at 7:47
  • 1
    Please edit your post, when you want to add information. Especially file or program output listings (with the help of the {} button in the editor toolbar) are much more readable there; alternatively you can use a pastie service for longer listings and include the link of your pastie in your question. Overall it’s best to have everything relevant in one place. Additionally, comments may be deleted for various reasons. – David Foerster Jul 16 '16 at 7:14

I found a workaround for anyone who might be having the same issue. No idea what the actual problem is but it seems as though setting the IPv6 settings "Method" section to "ignore" has resolved it.

  • I would like to know why, because this is happening to me too. I may try this and report back. – Aaron Apr 28 '16 at 18:03
  • 1
    I have this issue too. I have installed ubuntu in VMware 12 pro. Disabling IPv6 did not resolve the problem for me:( – user153245 Apr 30 '16 at 14:19
  • 2
    didn't solve the problem for me either. – lakesare Jun 13 '16 at 10:57
  • This didn't solve my problem. but clowning MAC address to another one get it fix. I really wondering what is going on ... – ucsky Sep 4 '16 at 14:16

Not sure if this will work. I also had this problem till I changed my Internet DNS servers to 8.8.8.8,8.8.4.4. Changed it for the IPv4 and it started working very well. Make sure you enter the values properly.

  • My /var/log/syslog had a bunch of lines about DNS, such as DNSSEC validation failed for question and Switching to DNS server ... for interface .... It's probably because I have a router right after my DSL modem. Setting the DNS server in the IPv4 settings fixed it – shadi May 27 '17 at 8:20

I got similar issue. "dmesg" shows some error on my Laptop:

[ 1755.216938] alx 0000:01:00.0 enp1s0: fatal interrupt 0x400, resetting
[ 1755.219706] alx 0000:01:00.0 enp1s0: NIC Up: 100 Mbps Full
[ 1991.252316] alx 0000:01:00.0 enp1s0: fatal interrupt 0x400, resetting
[ 1991.255396] alx 0000:01:00.0 enp1s0: NIC Up: 100 Mbps Full
[ 2045.330022] alx 0000:01:00.0 enp1s0: fatal interrupt 0x400, resetting
[ 2045.332851] alx 0000:01:00.0 enp1s0: NIC Up: 100 Mbps Full
[ 2095.727968] alx 0000:01:00.0 enp1s0: fatal interrupt 0x400, resetting
[ 2095.730059] alx 0000:01:00.0 enp1s0: NIC Up: 100 Mbps Full

I workaround this by change the "MTU" to 9000 (see https://bugzilla.kernel.org/show_bug.cgi?id=70761)

protected by Community Aug 3 '16 at 12:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.