7

Installed the released amd64 version of Kubuntu in a VirtualBox virtual machine - single CPU, 4096 Gb memory, 128 Mb video memory, single monitor. After install, following instructions from several blogs/websites, did :-

sudo apt-get update 

then

sudo apt-get install linux-headers-generic-$(uname -r) dkms virtualbox-     guest-dkms build-essential module-assistant

(linux-headers-generic-whatever already latest here)

sudo m-a prepare
insert guest-additions iso

install GA then reboot VM starts OK, logged in normally and the desktop/panel looks fine, window full screen. However, move the mouse pointer anywhere near the panel and it disappears. The desktop is not responsive and no right-click menu. Any program started via alt+ f2 also disappears on to the vanished panel. Moving the mouse pointer down shows the program pre-view but it is not responsive. I don't seem to be able to actually do anything so am unable to use this distro.

I have not tried to install to a hard drive yet.
Linuxmint 17.3 behaves perfectly BTW - so does ubuntu 14.04. I will try the ubuntu 16.04 release some time in Vbox and kubuntu 16.04 to HD later.

  • What is your base OS version – Scott Stensland Apr 23 '16 at 5:34
  • Host OS is Linuxmint 17.3. Additional info - installed Kubuntu 16.04 on a hard-drive this morning and this install does not not display the problem above. However, for this, wifi did not work initially - had to do "systemctl enable NetworkManager.service" to fix. Otherwise looks OK. – William D Apr 24 '16 at 11:20
  • 4096 GB of RAM, though... – fkraiem Apr 29 '16 at 13:47
7

There is a ticket #14102 for VirtualBox regarding this Problem. There seems to be a problem with 3D acceleration since Kubuntu 15.04.
Turning it off helped most times and worked for me. Hopefully VBox will fix it some time so we can use 3D acceleration again.

Update 28.06.16 There is now a wiki article about X11 Guest 3D that does not sound good for a quick fix.

  • 2
    Confirm turning off 3d acceleration got the desktop back and usable. Thanks. As you say, hopefully this will be fixed sometime soon. – William D Apr 24 '16 at 11:42

protected by Community May 2 '16 at 17:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.