I was trying to fresh install Ubuntu 16.04 on DELL 3521, Previously i was using 15.04. System was getting slow so i wanted to install fresh, I deleted the /, /boot, /swap and recreated. There are still two other drives (EXT2)

While installing i did select encrypt /home and continue in UEFI MODE The process was terminated after enter image description here

now i am unable to boot, I did tried both install Ubuntu or Try without installing using USB but it is showing error kernel panic.

enter image description here

Form the grub menu > terminal I can see the partition but no ubuntu files, I am helpless, what should i do now ?

Ubuntu Live USB wasn't working but Boot-Repair-Disk Worked Fine enter image description here

  • 'No known file system is detected', I've had this before. Did you allow Ubuntu to Encrypt the drive or choose the Wipe Drive & Install Ubuntu option? If not, if you don't have any important files on the drive, do a FULL format using EXT4, it seems to not be able to find partitions themselves, let alone the kernel/root. – Feg Apr 23 '16 at 2:42
  • I did select encrypt home, nothing else, The USB boot is not working, both install Ubuntu or Try without installing option are showing Kernel Panic Error. how can format now ? – Ramesh Apr 23 '16 at 2:49
  • 2
    What brand/model system? Looks like UEFI install. Do you have ESP - efi system partition on sda? Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info – oldfred Apr 23 '16 at 3:39
  • Oldfred he can't get to boot-repair because he can't use his USB to boot onto livecd(usb) to do so, also he can't boot into ubuntu because of kernel panick. Ramesh try unplugging the HDD and then trying to boot from USB, it may seem like it won't do anything but it happens to work quite a bit, after the USB boots plug the HDD back in, then post summary report. – Feg Apr 23 '16 at 3:59
  • 2
    Please don't add "solved" to the title. Consider posting an answer and accepting it instead. – muru Apr 23 '16 at 6:16

It seems like your harddisk is using MBR partition table and your are trying to boot computer using UEFI. Go to BIOS and change BOOT OPTION to Legacy, and try again.


I tried Boot Repair Disc and worked like a charm.


UEFI mode requires an "EFI System partition" (uncertain if that is the exact name in the partition tool).

/boot doesn't need to be a partition, as is the case with the rest too. (Generally better not, as it restricts / wastes space).

You will get the exactly same (first image) failure if the EFI-partition isn't there at the end of the installation.

The EFI system partition will get mounted to /boot/efi at the end of the installation.

  • I didn't find this to be the case for me. I have a partition for EFI, chose it for the bootloader installation (little drop down at the bottom) and it crashed anyway. I also tried with an ext4 partition and that also failed. Not sure what would make it happy. – Hendy Apr 29 '18 at 17:37

I have got the same problem when attempting to install a clean version without updating from the previous 15.10. It is rather confusing when you cannot boot and you have no other OS on your computer. My partitions are on a SSD : sda1 /boot, sda2 /, sda4 /home, sda5 swap. Other disks are reserved for data I solved the problem by deleting my sda1 partition and recreating a new primary partition formatted as ext4 with te same /boot mount point. And then installing 16.04 worked fine. Of course I don't know why, but it worked! In case this is useful. Eric

Not the answer you're looking for? Browse other questions tagged or ask your own question.