1

With Ubuntu 15.10 my Epson L355 printer installed without any troubles. Now, with Ubuntu 16.04 (Xenial) the printer's installation failed.

Before Xenial, I added to the sources list:

deb http://download.ebz.epson.net/dsc/op/stable/debian/ lsb3.2 main

And after that, installed the driver:

epson-inkjet-printer-201207w

But now, I get an error:

Depends: lsb (>=3.2) but it is not installable

I tried:

But, the error persists...

Can you help me?

1

The lsb package no longer exists in Xenial, so this package cannot normally be installed on it. You should wait for Epson to release a Xenial-compatible package, but in the meantime it should be fine to install the lsb- packages from Wily, since those packages do not install anything themselves (they only depend on other packages).

3

You don't need solve LSB problem... install driver directly and then add printer (automaticaly).

See https://askubuntu.com/a/763268/238367

2

After a few failures and getting the lsb3.2 error I installed the driver at the top of the list at: http://download.ebz.epson.net/dsc/search/01/search/searchModuleFromResult It reads.

WF-7520 Series
    Printer Driver  Linux
    latest  ESC/P Driver (full feature)     All language
    02-07-2012  

It installed without errors and gave me a whole lot of features, not available previously, like economy and draft mode printing. It prints from cassette 1 only at this stage, so a bit more fiddling yet to come. The new features are great and I'm happy to just swap paper trays for different size paper at this time.

I'm no expert (yet) so any further help I can give will be limited. I installed the 64-bit deb file using Gdebi. I believe this suitable for a host of other epson printers.

Package to download is epson-inkjet-printer-201115w_1.0.0-1lsb3.2_amd64.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.