I upgraded from Ubuntu 15.10 (on which the driver had no issues whatsoever), to the LTS version 16.04 a day back. I knew I would have to reinstall the wifi driver for my card(Realtek RTL8723BE), and as before I compiled the code from https://github.com/lwfinger/rtlwifi_new and installed it like always. But to no avail, because iwconfig shows me "no wireless extensions" and "modprobe"ing shows "error: required key missing". I think in the latest kernel ubuntu is looking for signed drivers? If that's the case then how should I go about it? I tried using different options while using modprobe as well (like ant_sel, ips etc) but still the same results. If that's not the case, then what should be the direction that I should start looking into?

Any help will be greatly appreciated. Thanks

up vote 7 down vote accepted

So, I figured out what the problem was. Since my machine runs on a UEFI BIOS with secured boot enabled, all the drivers that can be loaded onto the driver stack must be "signed". I think in kernel 4.4 Ubuntu, they enforced this sign verification quite strictly. That being said, all I did was to disable the secure boot from my BIOS setting (won't say this is a permanent solution) and now the wifi works like a charm.

  • 1
    My machine doesn't have UEFI, yet I still have this issue. Any pointers? – cat Apr 29 '16 at 21:50
  • @cat Did you go into your BIOS settings and look for secure boot option? It mainly has to do with the secure boot enabled and if it's enabled then any third party driver can't be loaded. Just try finding the secure boot option in your BIOS settings. – shivisuper Apr 30 '16 at 3:48
  • 1
    My laptop shipped with Win 7; it has no notion of secure boot (which I appreciate). Thanks anyways :) – cat Apr 30 '16 at 9:39
  • OK explain how on 15 it was working, but on 16 i have to do something in my bios??? – Vasil Valchev Oct 28 '16 at 7:44
  • 1
    @VasilValchev it depends on what kernel your distro is using. From kernel 4.4 onwards, the driver stack must be signed and thus it creates some issues – shivisuper Oct 28 '16 at 22:51

protected by Community Apr 27 '16 at 4:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.