1

MAAS 1.9.1 .....I deployed couple of nodes in MAAS and deployment went fine with 14.04 trusty image.....On my third node commissioning at PXE boot it start to look for Xenial image and failing with error: file not found ..... because Xenial is not in MAAS server....The only image i downloaded is 14.04 trusty......How can i make sure that MAAS server stick to 14.04 trusty image only for all my node deployment.....

regiond.log:2016-04-22 17:46:38 [maasserver] ERROR: Unable to identify boot image for (ubuntu/amd64/generic/xenial/commissioning): cluster 'maas' does not have matching boot image.

  • what is the default series mentioned in your environments.yaml file? – Junaid Apr 24 '16 at 7:21
  • there is no environment.yaml file – aavam Apr 24 '16 at 18:56
  • Never mind, i got it wrong. Have you looked at the logs in /var/log/maas/, it might be helpful. – Junaid Apr 25 '16 at 16:27
2

In the maas ui..go the settings>deploy options and change the Default Ubuntu release used for commissioning.

0

Looks like your operating system used for deployment has somehow changed to Ubuntu 16.04. Take a look at MAAS > Settings > Deploy or run

sudo -u postgres psql -d maasdb -c "select * from maasserver_config"

from command line and look for xenial right to default_distro_series setting (just don't post here the output of sensitive settings).

  • Actually somehow it changed to Xenial under settings --> deploy and commissioning ...... Changed it back to Trusty and everything went back to normal..... – aavam Apr 25 '16 at 19:27
  • @aavam: If this answer was helpful to you, then please consider marking it as the accepted answer so others may more easily find it in the future. This is also a polite way to thank the person answering your question for helping you out. – guntbert Apr 29 '16 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.